[SOLVED] BRD_SBUS_OUT = 1 doesn't work, any ideas?


I am trying to get SBUS signals on the SB(SBUS) connector of the Pixhawk. This works in AP 3.5.3 perfectly, no matter if I set BRD_SBUS_OUT = 1 or 2,3,4,5,6,7. It doesn’t work for me in any newer version including 3.7.1 (couldn’t find any working Arducopter version as well). I have power and signal on the ‘normal’ RC out connectors.
Are there any additional parameters I have to set or what am I missing ?

Thanks for helping

Edit: Setting RSSI_ANA_PIN =103 and reboot solved my problem

Yep this is really bugging me also. Can’t get and can’t find any documentation on how to get sbus out. If it’s not possible could someone let us know. seems to be a question that’s been asked since 2014 without answer.

As written above - this works for me.