Solid yellow LED when trying to calibrate ESCs?

I built a 600mm quadcopter with a Pixhawk flight controller. When trying to calibrate the ZTW Spider 30 amp Opto esc’s, I get a solid yellow LED from the pixhawk. I put transmitter throttle to full and plug 4s lipo in, and get the correct led light pattern for esc calibration. I then unplugg the battery and then plug it back in. Once the Pixhawk starts back up, I get a solid yellow light from the led. I have tried many times, and rewired several times, but get the same result each time. I have built 7 quadcopters with complete success, so I do have some knowledge of what I’m doing. Can someone please tell me what the yellow led means, and what I should look for to fix this problem. Any suggestions or information would greatly be appreciated. Thank you for your time, James.

I’m getting the same thing, running 3.5.0-rc3. I’ve blanked the firmware (loaded plane, then loaded copter), chosen frame type, run through accel/compass/radio calibration then tried esc calibration (using MP). Then unplug battery and replug and I get solid yellow light.
I’ve blanked the firmware twice and started from scratch and get the same thing…

If I plug the pixhawk in just using usb (no lipo power), it flashes yellow briefly then to solid red.

Similar problem here:

Its a safety check feature. When your Pixhawk throws a solid yellow LED while calibrating ESC, just press and hold the arm switch for 2-3 seconds and you should hear a beep. Now pull your transmitter throttle down and yours ESC/motor should beep confirming calibration. Try raising your throttle up to see if all your motors start at the same time.

Hi, I did this thing. And upon pushing up the throttle is started to spin.

My question is, once i turned off the pixhawk again the lights is now on and off Blue Color. How can I armed this? I tried pushing the Safety Switch until i get solid RED still got blinking BLUE LED. And once i up the throttle it wont spin. any Idea?