Soft-reboot with battery connected fried motors?


I think I fried my motors with mission planner. Please help me prevent that in the future.

I tried QGroundControl yesterday after failing to run Mission Planner1 on my mac and after realising that APM Planner 2.0 does not offer much in terms of vehicle setup.

I love the tool! It’s nicely designed, it seems to have most functionality, it’s opensource, and it runs on all platforms. I was even able to setup my compass, accelerometer, and radio and configure the flight modes.

Sadly however, after clicking “Reboot” (see screenshot below), I saw two tiny clouds of smoke coming out of my front two motors (motor 2 and motor 4) of my X-quadcopter.2 I couldn’t take a picture, but it looked like the smoke that comes from a candle when you put it out, or, if I had to make a guess, like the smoke that is generated when the coating of copper wires is melted away.

I am not sure what exactly happened, but what I do know is:

  1. The motors were soldered correctly, as I flew the quad using Betaflight 2 days ago.
  2. I had the battery plugged in, as I needed that so that all of the sensors have power during configuration, even though I believe to have read “somewhere” that this could end up frying things.
  3. The ESC still seems to be doing stuff even with the post-smoke (fried?) motors, as the ESC Calibration process still does result in two of the other motors twitching and sounds coming out of my quad (buzzer?) when I click on “Calibrate” in the “Power”->“ESC Calibration” section
  4. The ESC refuses a connection from BLHeli. I am not 100% sure whether BLHeli worked before with Ardupilot as the only time I used it was when the quad was running the Betaflight firmware.

What I don’t know is:

  1. Whether the motors are really fried and what the best way to test3 that would be? (the quad has never moved after I put Ardupilot onto it)
  2. Whether it is the motors or the ESC that would be fried? I will take the quad apart today or tomorrow and update the thread.
  3. Why on earth a soft-reboot would fry anything and if it these motors/ESC really are fried, whether there would be a possibility to prevent that for other users?

So, while I’m waiting for a new set of motors to arrive (fingers crossed I won’t have to also buy a new ESC), I thought I’d reach out to you for any comments or answers to any of the above :slight_smile:

Many thanks for your help!


1 I tried both using mono which didn’t start and complained about a dll missing (same as here) and the native version, but this one didn’t want to connect to my quad (and looked terrible!)

2 I am running a Mamba Stack Basic F405 Mini MK3.5 Stack 40A 6S 8Bit connected to four T-Motor F1103 8000KV Motors powered by a GNB 550mAh 3S 80C LiPo Battery

3 I did see this video on fried motors, but mine don’t have any similar burn marks. I also saw this video on fried ESCs and will definitely take the quad apart and check my ESC for similar marks.