Small icons in mission planner unusable HELP!

Anyone have this problem?

when mission planner first starts up it looks fine. then in a min or two everything gets really small and cut off.

this is another pic

I have exactly the same problem on my Microsoft Surface book running Windows 10. Changing resolution, icon sizes, etc has no effect. I also tried uploading earlier mission planner releases to no avail. Standard resolution on the surface book is 3000x2000.
The latest edition of Mission Planner works perfectly on my Windows 7 laptop. Any help would be hugely appreciated!

believe it or not I got it to work. I don’t really know what one did it but I was messing with 2 things…

I downloaded a direct x driver that was on the mission planer / ardupilot website ( I uninstalled mission planner and reinstalled it after the driver install

Also I clicked on the “check for updates” in the “help” tab on the top of the screen.

I wish I knew what I did… But your in luck!!! I well be installing MP on my dads Surface pro this weekend… I will update you if I figure it out!

I’ve seen this problem with other software. Some software, as written, isn’t compatible with high resolutions screens. I have a 4k screen on my laptop. Even if you set the resolution to something less, the program doesn’t render properly. The other times I’ve seen this, I was able to fix the problem by going to the .exe file for the app, select properties, compatibility windows 8.

Just tried with mission planner. No joy! The previous version of mission planner worked with the same laptop. With the way mission planner is currently rendered, I can’t even find the update icon.

This sucks!


This appears to be fixed in the beta update. Thanks to Michael and the mission planner team for the fast action.

Be sure to select the help menu prior to connecting to the drone. Like many things it’s obvious after the fact.


I’m still stuck with the same issue - icons and menu detail too small to read. Have upgraded to he latest beta software, re-installed Mission Planner and even checked for new display drivers. Maybe a specific Windows 10, Microsoft Surface Book Nvidia issue? Any help appreciated!

I use a surface as well. The issue is DPI scaling. It worked properly and MP worked properly prior to the last update at least on my mine.

Setting display and DPI scaling to default fixes it on mine for now.

Of course you need the Hubbell to see the text now :slight_smile:

Yep I can confirm the same issue on a high res surface pro3. It seems the scaling in display properties only affects text but not the text fields they are displayed in so text is hidden etc, maps don’t show fully.
Worked flawlessly before but even the Beta update doesn’t fix this issue. Hope this gets resolved soon.

Edit: Setting scalling to 100% (in effect turning off) and lowering resolution helps but still things are not displaying correctly 100%, positioning is often off.


Follow these instructions:
but do not download resource hacker just skip those steps and only create the manifest file and than do the regedit thing. restart your computer and mission planner will remain how it looks when you open it.

You’re welcome

1 Like

I also have display problem similar to what the OP describes. Windows 10, with a 3840x2160 resolution on a Lenovo laptop. Running MP 1.3.52

One workaround (far easier than the one outline above) is described here