Slow telemetry rate with Copter 3.6.2 ChibiOS

Hi all,

I’m having problems with the telemetry data refresh rate. I’m not sure if the problem is coming from the copter or mission planner though. However, the problem started since I flashed Copter 3.6 with ChibiOS and that’s why I decided to post it here. What I’m experiencing is a big delay (around 5 sec) on Mission Planner when it is connected through the radio module (see Mavlink Inspector figure), but when it is connected via USB everything runs very smooth and can’t notice the delay. I believe the parameters are set correctly, MP is requesting 10hz data (see sr1 parameters figure).

I ran out of ideas of what could be causing this and it is hard to believe that the CPU is running overloaded because the copter flies just fine. Maybe the RFD900 is getting overwhelmed by all the data?? Hope someone can give me a hand on this.

Here is my hardware setup:

  • Pixhawk Cube 2.1 running Copter 3.6.2 with ChibiOS
  • RFD900+ set to 57 baudrate, 64kB air speed, send Raw data, RTS CTS enabled (I’ve tried other setups like send Mavlink packets and RTS CTS disabled, but no change)
  • Mission Planner 1.3.59 (I also tried 1.3.61 but same story)


Txs for the report. How are you seeing the 5second delay? If you rock the vehicle back and forth the response on the HUD is delayed that much?

Are you see the same issue with Copter-3.6.2 on NuttX and/or Copter-3.5.7?

My guess is that it’s the radio that’s causing the delay. The RTS/CTS is a good thing to try (which you’ve already done) because that could certainly cause a problem. If the radio has 6 wires connecting it to the flight controller then RTS/CTS should work. Turning it off is always a safe option though because it will just lead to lost packets (but not delayed packets).

From other radio modules I know that they also cause a delay of several seconds when they got overwhelmed with data. I would try to reduce the number of messages.