Skydroid T10 in reality bricked when updated to the 5. 3 firmware version

I have now purchased 4 Skydroid T10. Use them for boats. And in general I am very pleased with the hardware, the performance and the device helper app that is linked in the user manual by QR code.

The app has, amongst many things, a built in ability to check if the remote or the receiver has a new firmware available. And ability to perform firmware upgrade. All very nice.

I have now upgraded two of my remotes and one of my receivers with a version stated as 5.3 (2021.4.8). And that was obviously something I should never have done, even though the app clearly stated it was needed/recommended. Because afterwards the remote can no longer connect to the receiver. Not pair with other receivers either. Pairing process is so simple, just put the receiver in pairing mode and turn remote on. With 5.3 firmware the remote loose the pairing to the current receiver. Can no longer pair with it afterwards. And also cannot pair with other Skydroid receivers. I have a few, and it is simply not possible. So the 5m3 version bricks, or at least render useless, an otherwise fine product.

Now. The device helper app has a handy feature. And ability to also pick a firmware file locally in addition to autodownload the most recent. Great idea. If only previous firmware was made available. So far I have not found any source. So it is not possible.

I have two friend using the same remote. They have both tried to contact Skydroid to ask for older firmware that hopefully can revert the gear back into a working state. And generally speaking there is no response at all. I bricked my second transmitter today. And if I had called my friends first they would have told me to stay away from any update. Sadly too late.

Does anyone know of a source of previous firmware for Skydroid? T10 obviously my focus. There are some really lengthy Skydroid discussions here with representatives advocating their products. If you read this, please help. Because this situation is nothing short of bad. The equipment is not cheap either, so I think Skydroid’s customers deserves answers on support requests. And old firmware versions cannot be too much to ask for. Not to forget that bad firmware should be removed from download to avoid further bad experiences for the customers down the road…

Is this the same System being sold on Amazon for $130?

Yes. That’s the one. I bought my last one from 3DXR in UK, a shop I regard as a serious actor. Wrote to them as well hoping for some assistance. Gear is good, until it is basically wrecked by their own software.

here the same probleme with the t10 after update its not working any more after two message to sales01@skydroid.xin i have nor reaction so i go to messenger on fb page thear is a bit off reaction not mutch but dear say send mail to that mail adres i post so, service is zero. way they do that its not difficuld to set firmware on dear site so that you cane replacet in the transmitter and rx…

I agree that skydroid should have helped you by now, so don’t take this the wrong way… but do you think you made a mistake by updating the transmitter first, before updating the receiver? this is the wrong order, and will cause this problem.
if you updated the receiver first, then the transmitter, then there is something very wrong with the update or the update method.

just on the fb page the talk you must update first the rx and after the tx in the manual its don dicripted.
i do it in the wrong way olav dit it correct and have the same probleme

A month back I only updated the transmitter. This can afterwards not pair with any receiver I have.

Yesterday I updated the receiver, then the transmitter. The receiver I can pair to another device afterwards (tested with a H12). But it does not work properly. I get a green light with blinking red. And it for sure does not work properly.

The receiver I upgraded (after the transmitter) can no longer pair with the updated transmitter. I did not bother to test with others, I already know the result.

Instructions are far below par. The firmware update page in the app only states in English that you need to do an upgrade and then lists in Chinese a highlight history of previous firmware versions.

This should be a simple fix from Skydroid support, to downgrade by offering old firmware versions. The app has the ability to pick a local file already. If, by some chance, that is not at all possible to downgrade and you risk ruining your gear by performing an upgrade then I really don’t want to express how I feel about it in this forum…

I did do an upgrade this winter. A version prior to 5.3. Only did transmitter. And had no problem at all. If it is true that we now need to upgrade in an order then I assume the new firmware is not backwards compatible…

@SKYDROID Can you chime in and assist in this issue?

Thanks in advance.

Great relief. There was a way to downgrade. Using the newest device helper app, and selecting demotion device. After demotion I could downgrade and problem solved. My two T10s are back in business. Don’t care to try again, not for a while.

Found the answer here…

1 Like

Hi , all
I facing this problem , I got firmware from them (SkyDriod) , first to need to downgrade your TX to 1.4 that I had upload with this reply , then you can bind your RX and upgrade your RX to 5.3 first then update your TX finally
Have a nice firmwaret10-1.4.bin (44.3 KB)

1 Like

I have the same concerns that you have with my T10 … I try to downgrade the firmware but it doesn’t happen … Nothing to do I can not downgrade grade from version 5.3 to version 1.4.
Can someone help me and give me the exact procedure because I can do nothing to help.
thanks in advance

Yep , I think many people facing same my problem.
to bind them (R10 and T10) you need to downgrade T10 from 5.3 to 1.4 first , then you will can bind to R10 that still 1.4 firmware , after that you can upgrade R10 to 5.3 before T10 to 5.3 then will smoothly bind together. If you Can’t download t10-1.4.bin link below let me know you e-mail address I will sent again please.
t10-1.4.bin (44.3 KB)

Thank you very much for your answer
My problem is not to download firmware 1.4 but it is in the process To downdrade to version 1.4.
I do not know if I am making a mistake in the handling but nothing helps. The wheel turns nonstop and I stay on version 5.3.
Thanks for your help if you can explain the procedure to me.
My email address: capbreton@gmail.com

Hello Guys, do you have somebody some experience with H16 radio? How to connect it to Pixhawk 2.1? I cant connect telemetry data through Telem1 to UART0 of H16. RC ground station dont see it. The same problem is with video from HDMI port and channels 1-8 are working but 9-14 are not working. QGC installed to H!^ ground station report me than UDP post ant be connected because is in use. Please could you help me?
Thank you George

This happens. Unless knowing chinese, in general for Skydroid you can do the following:

  • Capture screen on tablet on the Android application (Vol- + on/off).
  • Copy image to PC.
  • Isolate the chinese characters on the .png obtained.
  • Upload the image to some online chinese OCR service: it will give you the chinese characters as text.
  • Copy and paste the chinese characters on Google Translator (thanks, Sergey&Larry)

All this shows Skydroid terrible way of doing things and service:

  • Chinese characters are common using their applications.
  • They seem to think that everyone knows chinese, or only think in chinese users.
  • Since support is null (web, email, etc), above procedure is what has to be done.

Hi ., I have no idea for H16 but you can contact SkyDriod directly via WeChat please