Servers by jDrones

Skidsteering more "throw"?


(Max) #1

Hey what parameter is related to skid steering throw

beta 3.0.1
skidsteering_out 1
radio calibrated

in maual mode with 100% “right” it only turns veeerrrz slow.
forward/backwards works great.

thanks


(gmorph) #2

There are a number of parameters for auto mode but as your in manual mode it is basically straight through except for the skid steering mixing. Make sure your radio is calibrated correctly. RC1 is probably your steering channel as its the default so make sure you have full thrown on that.
Please attach a log file and I’ll have a look if the radio calibration doesn’t help.
Thanks, Grant.


(Max) #3

Hey Grant,
no doesnt help.

i have a log file here for you:

Max


(Max) #4

i did some more testing :slight_smile:

i used skid steer out 1 so the pixhawk is mixing the skid steering normaly.
now i changed that and used skid steer_out 0 and let the sabertooth do the mixing (linear)
with that setting i can turn on the spot with no problem in manual mode.
so its not a rc calibration problem.

the internal pixhawk skid_steering_out 1 is just not gonna use big enouth throws (and it starts with the outer skid first, not the same throw on both chans !
i want the pixhawk to do the mixing for auto missions (and turning on one possition)

are there any parameters to change that?

log file with skid_steer_out 0 (sabertooth does the mixing)
log file with skid steer_out 1 (sabertooth doesnothing)

video of skid steer 1 behaviour (trottle forward backward is 100% linear.)

maybe a bug in 3.0.1 ?


(Max) #5

i fixed it with a workaround, i just ajusted the “max/mid/min” settings in the sabertooth to 1300 1500 1700 and now i have enouth range. i limited the max_trottle / cruise trottle now it can turn with skid_steer_out 1.

i have a log here of several auto missions.


(gmorph) #6

Glad you got it fixed. Those sabertooth settings don’t seem wide enough. Is there a reason your limiting them?
Note in the log you attached THR_MAX is still 100.

Thanks, Grant.


(Max) #7

the reason i limit them (and not use 1000 / 1500 / 2000 ) is that i need more “power” in steering.
with normal range there is not enouth power to turn in auto or manual. but more than enouth for forward/backward) so its a pixhawk problem, with too less throw in steering

yes i removed the thr_max for that testdrive, but its too much power :wink:

now normal driving is good, it breaks a bit bevor steering. but if the 30degree skid steering on the place kicks in its a bit “hard” (you can see that in the third and forth turns in the automission in the log). whats the parameter to smooth that?

thanks a lot Grant zour realy helping me out!


(gmorph) #8

I think its your steering controller - you have your P term far too low. Change STEER2SRV_P from 0.3 to 1 and if that doesn’t help try 2.
Let us know if that helps.
Thanks, Grant.


(Max) #9

Step 3: Setting the STEER2SRV_P
To set your STEER2SRV_P parameter you need to measure the diameter of the turning circle of your rover.

Put your rover into MANUAL mode, and put the steering hard over to one side. Then very slowly drive your rover in a circle. Use a tape measure to measure the diameter of that circle and set STEER2SRV_P to that value in meters.

its 0 meters for me. but i will try thanks


(gmorph) #10

Yeah I know - that info is really for “non” skid steering Rovers - I’ll have to update it with some good defaults for skid steering rovers.
Thanks, Grant.


(Max) #11

ah ok :slight_smile:
i have a 3 hour tuning maraton on monday so i can find out good values for you if that helps.

if you want me to do any special procedur just tell me, i help were i can!


(gmorph) #12

I always love to see a video of a rover in action - warms the cockles it does :slight_smile:
And a log file of a happy well tuned rover - I like them too.
Thanks, Grant.


(Max) #13

ok will do that :stuck_out_tongue: hardware seems final now…


(gmorph) #14

That is a great looking rover - what’s it for?
Thanks, Grant.


(Max) #15

Here you have a video and the log of that auto mission. Hope you like it !


Its for autonomous measuring.

what do you think could be improved?
i think the “trottle” after the 90degree turn on the spot is a bit too mutch.

i will add a log with more driving later


(gmorph) #16

Great video - thanks heaps!
Maybe change the THR_SLEWRATE if you want it to accelerate better after cornering? Give it a go and let us know how you get on.

Thanks, Grant.


(Sebastian Schürmann) #17

The skidsteer implementation in Ardurover uses only 50% of the steering input for turning.
It is not a true tankstyle steering, because while pivoting, the left and right wheels go only to 50% forward/backward and while driving at full speed and max turning, the inner wheels brake to 50% instead of stopping.
It makes it nearly impossible to turn on the spot with some rovers on certain surfaces.


(gmorph) #18

Hi Sebastian. It would be great if you could update the code and submit a PR to improve the skid steering control.

Thanks, Grant.


(Khancyr) #19

I got the same problem and initially, I change the 50% to 80% to allow more power (changing parameter here https://github.com/ArduPilot/ardupilot/blob/master/APMrover2/Steering.cpp#L287)
Then I try to make this 0.5 as a parameter https://github.com/khancyr/ardupilot/commit/c8c1290aba408b8821022fa5ec430ae2d3930286 .
But I don’t think it is the right think to do. I reviewed my rover parmeter (specially CRUISE_SPEED CRUISE_THROTTLE etc) and I can reach nearly 100% turn speed (according to log pwm output)


Pivoting speed parameter & arming via transmitter
Pivoting speed parameter & arming via transmitter
ArduPilot with Dual GPS (blended)
(Andrés Ábrego) #20

Hi!
I am having the same issue, pivot turning too slow.
Which is your recommendation? Tuning the mom/max values of the ESC’s? Is the skid_turning_ratio ever going to be implemented in the official firmware? Is there any way to implement it myself?