Skid steering isn't working

My apologize if I’m wrong but I cannot get skid steering working anymore!
It was working fine autumn 2015 (and it still does with that release) but with newer firmware versions there is NO output to port 3 meaning the rover cannot move.

How come this has stopped working? It isn’t hardware related as previous firmware version are working.



Rover 3.0 introduce arming.There is currently a bug in arming in skidstreeing mode.
So before drive you need to send ARM command.
Or you can disable this : see ARMING_REQUIRE parameter.

Thanks a lot!
Now my rover runs again. I still have some acc-calibration issues but I’ll probably find what’s wrong as I have no problems with my octo and planes.


Sorry Andres that I didn’t get to your email but as you can see there are lots of clever people here who can help - thanks khancyr! If there is a bug in arming skid steering would you be able to log an issue on github and post the number here?

Please provide all details and replication steps you can and any logs you have. That will help us solve the issue.
Thanks, Grant.

As the motors on one side engage without arming must be considered a bug!
Implementing Arming is a good feature, I think, but as the rover will go circles only, until armed, isn’t correct according to me.


@gmorph : I submit a PR to solve this issue
But as I explain, it need testing

I tested also and confirms that skid steering is broken in release 3.0.
I documented the bug here:

Have you been able to ARM the rover?
The other option is to disable ARMING_REQUIRED as written above.

Disabling ARMING_REQUIRED made my rover run as expected


Thank you Anders, by disabling “arming checks” and “arming required” params, I could then get a normal skid steering behaviour. What a bug ! But at least we have a workaround.

I’ve replicated the problem in the simulator so I should have a fix soon.
Note you should only need to disable ARMING_REQUIRED. You should leave ARMING_CHECK as is i.e. 1 as it will still run the arming checks and tell you if there is a problem - it just won’t prevent you from arming if there is a problem.
Thanks, Grant.

cool thx. Looking forward for the patch.

When you fix this can you test that the log start after ARM, not before.
Now it does!


I created a new Beta release that fixes the issue. Please test and let me know how you go.
See here:

I am having problems getting the Pixhawk to perform with the latest release of ardurover,3.0.0, I have enabled the skid steering parameters and disabled all arming checks… Left ESC is hooked up to Main out pin 1 and right ESC is hooked up to main out pin 3. When I throttle up (left stick forward) the left engine responds and when I use the right stick to turn left or right, the right engine responds.

I have not yet tried the Beta release. I hope the Beta fixed everyone’s problems and will hopefully fix mine?..

Spektrum DXe with Satellite Receiver and Spektrum copnection
2 - ESC
2 - Motors

The ArduRover firmware is expecting you to use the Pitch (Elevator) joystick as the throttle input and not the Throttle joystick. Also, you might try connecting the right ESC to pin 2.
What are you using as an R/C receiver with the Pixhawk and what does you R/C MAP look like?

We are using the Spektrum DSMX Quad Race Receiver with Diversity connected via the spektrum input. I will provide a map when I can.

Just set SKID_STEER_IN to 0 . It should solve your problem

We were able to get the skid steer working by downloading the latest Beta version of ArduRover.

Great news that its working. If you have any problems with the BETA please let us know.

Thanks, Grant.