Skid Steer Dagu WIld Thumper no output on pitch channel

Hi all,

I posted in regards to this build almost a year ago - time flies.

I reviewed some prior posts about the wild thumper and sabretooth 2x25 - We have 2x12’ in its place.

Issue I’m having is that the pitch channel wont output so vehicle will move forward and back. I’m ony able to get it to spin on its axis on the roll channel.

I have dipswitch 4 in the up position to keep channels independent and have tried skid steer in and out attributed and not. No go. If I mix channels on switch 4 then the vehicle runs as soon as armed.

I had this working last summer but unable to replicate now maybe due to fw changes?

Here are the specs:

Dagu WIld thumper 6 wheel
Spektrum DX6 with PPM converter
Channels 1 and 3 in Pixhawk RC out, Pitch and roll channels used on PWM RX.

Oddly, one of my students had it working on both channels but after a few moment it would only operate on roll.

I’m using 3S batteries but dialed down PWM output on the TX to prevent over voltage - learned that the hard way - replaced all motors due to lack of thermistor protection.

Any advice welcome! TCIII helped a year back, hope you are still able to!!


further info:

On first bootup I get pitch and roll action with skid steer in at 1 and dip switches 1 and 3 down on sabretooth. After a short time the pitch channel no longer activates motors.

What Firmware and is this a Pixhawk?


David R. Boulanger

I have built two 6WD Wild Thumpers using a Pixhawk and a Sabertooth 2X25 and never experienced the issues that you are having.
Here are my settings for the Sabertooth 2X25: 1 OFF, 2 ON, 3OFF, 4 OFF, 5 ON, 6 OFF.
The Sabertooth ESC should NOT be in the mixing mode!
Only SKID_STEER_OUT should be 1.
What does your RCMAP_X look like?
What is the brand of your R/C equipment?
Are you using a PPM Encoder or a receiver with a PPM output?


Thanks for rapid response.
I’ve attached two screen shots

note I have changed throttle channel to pitch in the RC_MAP.

I am using Spektrum DX6 with a PPM converter. On the Spektrum AR610 I have lead 1 plugged into Aileron and lead 3 in Elevator. I have the esc leads plugged into MAIN OUT slots 1 and 3.

With dipswitches set as directed I am only able to get output on one side of the rover and seems like it is reduced out put.

Rover FW is 3.01 (current)

Please attach ONE of either a tlog or bin (dataflash) log file when the problem occurs and I’ll have a look.
I can’t help you with the sabertooth ESC as I don’t have one but make sure its set to “simple” mode - it shouldn’t be doing any of the mixing.
Thanks, Grant.

Thanks Grant, I’ll definitely do that on Monday.

Here is a link to the Ground Rover Logs. Thanks for your help!

Have you tried to disable all arming checks? This is a current bug in rover 's firmware for skid steering. With arming disable it solved it for me (also a wild thumper with sabertooth esc)

Thats what I will try next Hugues.

Which Sabretooth are you using? Ours are 2x12. One of my students burnt out a motor in his team’s rover today. It was not in motion but could hear some high pitch whine - my students pointed it out and as I looked I saw smoke coming from center motor.

With settings as is I was getting output on one side of the vehicle on 1 channel. It seems very underpowered.

Can you share your specific rc_map and other rover specific settings?

Thank you !

Hi Steve. Its easier for me if you only provide 1 log file that has the issue rather then a bunch of log files and I have to figure out which one. I looked at the log
2016-06-17 13-28-04.tlog
The steering is on channel 1 and I don’t see you holding the steering stick over for long enough so that the rover would arm.
As for the throttle even though you want to use the “pitch” stick on your transmitter to control the throttle it still needs to be mapped to the ArduPilot throttle channel. ArduPilot needs to know what channel the throttle is and this is set by RCMAP_THROTTLE. So whatever channel the pitch stick on your transmitter outputs you need to set RCMAP_THROTTLE to that. Alternatively you can change the pitch stick output channel on your transmitter to match RCMAP_THROTTLE. Make sense?
Note I can see in the logs that channel 2 never moves and you have RCMAP_THROTTLE currently set to 2.

Thanks, Grant.

Hi Hughes. The 3.0.1 rover software should solve the arming problem. Have you upgraded to this version of the software and re-enabled your arming checks and tested? I’m keen to get your feedback so I know its working.

Thanks, Grant.

Thank you Grant. My students and I will report back our findings.

I seem to recall not requiring an arming stick maneuver when using the pixhawk on a rover - could this be?

If I have the left stick not utilized. how would I arm without giving input?

Hi Grant, not yet. I try to test it this week end and will report back. Sorry for the delay in testing, I know I promised and I will do it.

I’m using the same : 2x12. my settings are the same on the Sabertooth as what Thomas said above. My RCMAP settings are ther default ones.
I did have to specify on my Taranis radio that I wanted Pitch to be used also as throttle stick. That is an extra channel mix you have to configure on your radio, if not already done.

Wing tail mix on Dx 6 Elevon?
I think we tried this mix but since many things have changed will retry.

Hello @TCIII. I want to ask you. Why you are not using the mixing mode. I have rover with fixed wheels. But i can not turn. It have to be something with mixing mode?