SIYI A8 mini 4K AI Mini Zoom Gimbal Camera - AI Identify & Tracking, 4K 1/1.7-inch 8MP Sony Sensor, 6X Zoom

Another test today with ArduPilot 4.5.0 beta 4 and the camera 0.2.4 and gimbal 0.3.6

Yesterday I powered and armed the vehicle twice and got 2 videos on the A8 Mini SD card:
rec_0000
rec_0001

today I powered and armed the vehicle once.

The rec_0000 file was overwritten with the video from today, but the rec_0001 file still had the video from yesterday. The rec_0000 video file from yesterday was gone. I hope that’s clear.

1 Like

Hello everyone.
I’m currently using an A8mini connected to Cube Orange. It operates normally when facing downward, but when facing upward, the gimbal’s posture becomes unstable and unusable (it keeps shaking). Connecting the telemetry cable to the MK15 receiver or powering it downward before turning it upward resolves the issue. Am I the only one experiencing this symptom? I would appreciate it if someone could provide any necessary parameter adjustments. Thank you very much!

I got my A8 and put it to test. take a couple of shots. As we can see in the image, it is blurry and not a good quality image to look at. The camera with the Assistant app has zero settings in terms of camera setting, iso, white balance …
Do I miss something?

1 Like

Does facing upward here means the upside down mode? And you are sucessfully integrating the flight attitude data in normal mode, right?

Thank you for your reply! Yes, I can operate normally in the regular mode (facing downwards) without any issues. However, when I switch to upside-down mode (facing upwards), I struggle with posture control. This occurs specifically when connected to the Cube Orange. I would appreciate it if you could let me know if there are any settings that need adjustment or potential causes for this issue. Thank you in advance!

I think the reason is that A8 mini has not supported flight attitude integration in the upside-down mode
How exactly you are using in this way? Mind if we see any pictures?

I have a UART cable (connected to GPS2 port) and an external cable (connected to the MK15 transmitter) running from the A8 Mini to the Cube (with a photo of the Black sub-FC). In Mission Planner, I’ve set the parameters as follows: SERIAL_PROTOCOL = 8, CAM1_TYPE = 4, MNT1_TYPE = 8. The RC mapping and other settings are mostly according to the manual. The reason I want to use the upside-down mode while connected to the Cube is to tag images with geotags. However, if there’s a way to tag images without connecting to the Cube, that would also be acceptable. Thank you for your assistance.

Additional note: If it’s possible to trigger the camera remotely, I believe I can still tag images with geotags, so that would be acceptable as well. Also, I have a A2mini and ZR10, and I’m wondering if it also doesn’t support integrated posture control in upside-down mode?

I apologize for the numerous questions.

My name is Sid, and I’ve been encountering some difficulties with my Herelink v1.1 system while trying to connect it with a Siyi camera for my drone. Initially, when I connected the camera with the Here-Air unit (ETH), everything worked smoothly. However, after a few days, the connection ceased to function.

I’ve tried troubleshooting the issue myself, but haven’t had any luck so far. Could you please assist me in figuring out how to successfully stream video through Herelink with the Siyi camera using the ETH connection? Additionally, I’ve found that everything works perfectly fine when using the HM30 module. I also have your Mosaic Camera Module, including A8, ZT6, and ZR30, all of which function excellently with the HM30 module. However, when I attempt to use them with Herelink, they stop working after a few days.

Your guidance in resolving these issues would be greatly appreciated.
@SIYI

I have my Siyi A8 mini connected to a Cube Red via a UART, and it works fine for gimbal control via RC targeting and gimbal tracking, so now I was thinking to get the A8 mini to capture a bunch of photos using a survey mission.

I went into mission planner and selected “Auto WP” after creating a polygon, then selected Survey (Grid). The selectable cameras did not include any Siyi cameras, in particular the A8 mini. Will the survey mission work as generated without selecting a particular camera? Are there any recommended settings in the mission?

1 Like

What is the A8 mini firmware versions your are currently using when connected to flight controller .

I had the two issues with A8 mini latest firmware

  1. When I try to do the continuous YAW and PITCH control of the gimbal it’s not continuously rotating instead it might get stuck at random points ( at least 0.5sec) both pitch and yaw axis .
    But this problem went away when I downgraded the A8 mini to the very basic version like 0.1.7 .

  2. As your earlier post about the recording issue it get overwritten the older video with same file name.

1 Like

I’m running the camera with 0.2.4 and gimbal 0.3.6.

I haven’t tried continuous yaw and pitch, but I do notice some glitching (sticking) when using tracking mode, but I"m not sure if that’s the camera or mavlink connection delays/latency.

I believe there is a new firmware coming that might fix the file overwrite issue.