SIYI A8 mini 4K AI Mini Zoom Gimbal Camera - AI Identify & Tracking, 4K 1/1.7-inch 8MP Sony Sensor, 6X Zoom

Please try in flight test
The way you are trying is a very harsh situation in flight, I can only imagine fixed-wing rolling over for this situation. However, if I was wrong, please feel free to let me know.

cool! I will test the new firmware soon. please tell me, can you still fix analog cvbs video. It is very bright. As you can see, I’m not the only one with this problem.

It is baffling to me how SIYI designed a gimbal where the camera hits the frame beyond 30 degrees of roll. Honestly – I saw this and I put mine back in the box and have not really looked at it since. It just seemed like prototype beta effort. I do plan to use it on a plane at some point soon and I cannot complain that I paid a fortune for it. But still you really need to fix this silly flaw for a v2 version. Also the behavior exhibited in that video – getting stuck – is something I would not have seen in my Storm32 gimbals circa 2015. We do appreciate SIYI engaging the Ardupilot community though and all the mavlink gimbal support that is happening.


I can not get the camera to update to 1.9, I follow the process but the app is still showing 1.8

Edit got it in the end

Use FAT32, it should work

updated firmware but now I lost pitch. There appears to be no pitch motor output but it is hot to the touch. I only have the SIYI desktop app for Win. Is there something I missed? I lost control over SBUS. It was mapped to channel 7 for pitch but since the update or the attempted calibration the gimbal has lost pitch function and control. Does this new feature have anything to do with the above issues?
New feature: Six way gimbal calibration by customer

Your instructions and app need better development and translation to English. It is difficult to understand.


I bought an a8 mini. I’m trying to install siyi assistant on my pc, but it doesn’t work
I use windows 10 pro
What more do I need to do?

Hi @Marc_Dornan,

I’ve just tested the latest A8 firmware (0.2.7) and it seems to have resolved the issue where the vehicle would lose attitude control if the roll or yaw when beyond the gimbal’s physical limits.

UPDATE: Tried reinstalling firmware. Same results. Gimbal doesn’t work but camera works.
Does anyone have the older firmware? I want to try reinstalling the old firmware to fix the gimbal. Tried calibrating with no effects.

That’s good Randy. I do appreciate all the mavlink support the A8 is spurring. Def time to fly mine and I hope SIYI will release an A8 gimbal that fixes the strange physical roll limits.

1 Like

Siyi, maybe you can consider to release open sourced firmware so than community can help with fixing ton of issues, as now we have only good looking camera stored in our drawers.


Hi, I got my A8 mini gimbal. after many attempts with it to work with Siyi mk15 (ethernet) for 3 days I discovered it is outputting the video to HDMI and not ethernet by default as said in the user manual. my question is how do I change the output from HDMI to Ethernet since it is not connecting to the Siyi FPV App.

Change the output mode from HDMI to close state in siyi pc assistant…this will make default output as ethernet.

1 Like

Hi, I did just that but I could not get it working even then. Neither did the gimbal mode changed (Follow/FPV/Lock). I am really feeling frustrated since its both siyi products and should work out of the box. I’ve also upgraded the camera, gimbal and the siyi fpv to the latest they offer. Any help would really be appreciated.

Today I installed new software. Updated everything, gimbal, camera, siyi assistant. I really hoped that you would fix the problem with the horizon being blocked, as well as the output of cvbs analog video with a large exposure. The new version of the firmware has not changed anything! The gimbal works relatively fine in fpv mode, but why can’t I keep this mode forever?? Why did you make these modes if you can’t save them in the settings? Please answer me, many people have bought cameras from you and can’t use them. When will you fix the problem?

Im also having eithernet issues now, it was fine and its just stopped and cant get it to work at all with herelink, tried multiple devices and AIR sides. nothing

@Vishal01Mehra @MadRC

For video output issues, if you have done trouble shooting but there is no success. Please send all the relevant information and let’s check together.

1 Like

SIYI any word on my issues? I sent emails to both the vendor from whom I bought it from and your support email.

@SIYI Thanks. I had the Ethernet switched off by default in the Android which was causing it to not connect to the camera. Now the camera is working well but the mavlink connection with the Pixhawk is not loading the full set of parameters. It stops at about 80% in QgroundControl also I looked at the lost data rate of mavlink and it is suspiciously high at around 20-28%. Any solution to that?

has the ai tracking feature been released yet?