SITL Quadplane Simulation

For ArduPlane Version 3.7 I used the command: “ -L KSFO -f quadplane --console --map” to build and launch the simulator as directed here…

This no longer works.

It keeps telling me quadplane is not an option.

Does anyone know the new command or what the problem may be?


That command worked fine for me (using Cygwin under Windows).

Is there a particular reason you’re using Arduplane 3.7 rather than the latest source code? Does the command work with the latest source code? Does it work with different frames (like plane or hexa)?

What I was trying to say was it worked for 3.7 but not for the new 3.8 beta code.


very strange, I just tried it here and it worked fine. Are you sure you’re getting the right
Try this: type
perhaps a $PATH issue?

Turns out this was the problem…

Just pulled the master.

Looks like it’s still having the same problem.

FBWA> APM: Executing nav command ID #84
APM: Resetting previous waypoint
Got MAVLink msg: COMMAND_ACK {command : 11, result : 0}
APM: Reset alt target to -2.6
waypoint 1
arm throttle
AUTO> APM: Throttle armed
Got MAVLink msg: COMMAND_ACK {command : 400, result : 0}
/vagrant/Tools/autotest/ line 54:  3580 Aborted                 (core dumped) $cmd $* &> "$filename" < /dev/null
no link
link 1 down
no link
no link
no link
no link

Hello Shane,
I’m having the same issue, did you manage to solve the problem?