SITL on WSL don't work on new setup


I could do SITL in WSL before.

If you are curious about the setting I tried before, you can refer to this link :

I installed Ubuntu as WSL container,

and typed below command :
sudo apt-get update
sudo apt-get install git
sudo apt-get install gitk git-gui
git clone --recurse-submodules GitHub - ArduPilot/ardupilot: ArduPlane, ArduCopter, ArduRover, ArduSub source
Tools/environment_install/ -y(in ardupilot directory) Rover -A “–serial0=udpclient:” --no-mavproxy --custom-location=“2.48647,-159.45417,0,0”

with above command, I could do SITL in WSL before.

I installed SITL on my new laptop, and SITL can be built and run in WSL window without severe error message, but it won’t connect to mission planner.

in above screenshot, you can see font error which was not shown in the previous laptop.

It seems that something is changed with version up,
my old laptop checks like below :
Checking for python version >= 2.7.0 : 3.10.6

but my new laptop checks the python version like below :
Checking for python version >= 3.6.9 : 3.10.6

it seems that something is changed with version change and it makes my sitl impossible to connect to mission planner.

I tried to find the way to install xterm font but it was hard

I tried older version of ardupilot to build SITL,

but there was Parse Error Exception.
(the ‘@’ markup has been removed, just use ` instead)

Weird thing is,

when I build the SITL image and run at first time, it worked.

but after that it don’t work. Rover -A “–serial0=udpclient:” --no-mavproxy --custom-location=“2.48647,-159.45417,0,0” Rover -A “–serial0=udpclient:localhost:14551” --no-mavproxy --custom-location=“2.48647,-159.45417,0,0”

Changing command line like above make SITL connect for about 5 seconds, but it started to refused connection again.

I have two laptops and one laptop is working well and the other is not working well.

with well working laptop,

“netstat -ano | findstr :14550”

this command return the PID of ubuntu,

but with not working laptop,

this command don’t return PID of ubuntu. there is nothing.

Oh, I solved problem.

I checked my IP address with “ipconfig” command and replaced “” with that address.

but still can’t connect multi vehicle.

If I open two ubuntu instance, second one won’t connect to windows mission planner