Singlecopter on CC3D Revo

I am setting up a Singlecopter with CC3D Revo flashed with Quad FW.
Frame_class 8 (singlecopter). Frame_type 0 (for +Plus).
Motor 1-4 assigned to servo #1-4.
RCIN 3 assigned to servo#5.

All 3 channels (Ail, Elev, Thr) work, however, no servo work in response to rudder stick.

Pls note the green YAW bar in Radio Calibration page moves corresponding to rudder stick, meaning both Rx and FC work. (Param attached)
Have tried following but nothing work :-
Swap another FC (both FC work normally in other application) Tried another Tx Reboot everything Reflash FC with Quad fw Cancel arming with rudder stick
Pls help check the codes relating to the rudder channel of Singlecopter.

No .param file,
no .bin log file,
no firmware version information.

How exactly are we supposed to help you? :slight_smile:

Sorry for the missing info. I pressed the “post” button accidentally before attaching the param file. Except the settings I mentioned, all are default settings. Anyway, here it is.
Ball drone__param.param (14.6 KB)

Fw is Copter v4.4.2

.bin file is also attached.
4 1969-12-31 4-00-01 PM.bin (890.6 KB)
I thought bench testing file is useless for trouble shooting. That’s why I did not think of attaching.

When moving the rudder stick, all the 4 servos are supposed to move, but they don’t, as witnessed in the servo output page of MP.
Thank you for your help.

Which flight mode? Automated flight modes will not produce servo moviment while on the ground.
Is the copter armed?

It is Stabilise mode. Copter is armed.

Left and right servos move when I move pitch stick,
Front and rear servos move when moving aileron stick.
No servo move when I move rudder stick. All 4 servos are supposed to move to rotate the vanes either CW or CCW.
Above happened when copter is armed or disarmed.

I have tried flashing the FC with earlier version Copter v.3.x.x with same result.

Thanks again,


Could you please show me that part of the FW which instructs the 4 servos to move upon receiving signal from the rudder stick,
as I don’t know how to access the code ?

I guess changing the FRAME_CLASS to 8 (for Singlecopter) should accomplish
instructing the 4 servos to move to direct the airflow so as to neutralize the torque caused by motor rotation.

The servos move correctly in response to elevator and aileron stick movement,

Many thanks.

It is not that simple, there is no single place I the code where that happens.

You have something misconfigured, this is not a software bug.

I understand it may be complicated. The weird thing is, pitch and roll servos work, all with default settings except FRAME_CLASS, FRAME_TYPE
and 4 servo assignment to motor #1-4 in servo output page.

What may have misconfigured such that yaw does not work ?


SERVOn_FUNCTION comes to my mind.

Servo (1-4) are all left at default, and elevator and aileron work according to singlecopter behaviour (left and right servo move for pitching, and front and rear motor move for rolling). See attached. (awaiting servo delivery).

All 4 servos should move to rotate the vanes to compensate for the rotational torque caused by motor. But they don’t. I also agree with you that it is not software as I did flash the FC with previous version V3.x.x of quadcopter with same result.



After referring to the video of the same Singlecopter by another hobbyist on the testing of gyro (, starting at 7 seconds, I just realize that ALL the servos do not move in response to rolling/pitching/yawing of my Singlecopter.

The builder ( which I first followed used Diatone’s Mamba-F405MK2 as FC which runs on Betaflight, and said
Betaflight is just one option I used to get your drone in the air. All of the above steps can be done (not tested) using iNav as well, and I heard Ardupilot should do the job too!.

Servo response to gyro in FC should not need any adjustment or setting. Not sure if the singlecopter configuration really works in arducopter suite.

It works, there are videos showing wobbly hovers. But for every one of those there are probably several others that never fly. My guess is yours won’t fly. If you do work out the flap servo problems then you may find the small flap area to have insufficient authority for stability.
But, it would make a pretty cool Christmas tree topper!

The core problem is the servos do not move in response to the vehicle movement, that is no gyro response, I don’t know why.

The other problem is no yaw movement in response to rudder stick. While the other 2 channels (roll and pitch ) work, I suspect
could it be the hardware of the FC (CC3D series Revolution) ? But when I flash the same FC with the same quadcopter FW, with frame class set to
quadcopter, the yaw channel works.

I just have no clue.

Try searching the forum here for another Singlecopter that actually flies and review the posted parameter file for clues. There are not many but this one perhaps. Near the end of the thread there is one posted:
Singlecopter, for those that like pain

Hi Paul, Thank you for yr help. Below is the comparison of servo assignment between Pual whom you referred me to , and my setting :–

His setting My setting
Servo1_Function 33 (motor1) 33
Servo2_Function 34 (motor 2) 34
Servo3_Function 35 (motor 3) 35
Servo4_Function 36 (motor 4) 36
Servo5_Function 37 (motor 5) 53 (RCIN3) Throttle
Servo6_Function 38 (motor 6) 0

In my setting, the ESC is connected to Output CH5 of the Rx, so after I use his setting, as expected, throttle does not work,
and the 2 problems still remain. I am not sure how did he connect his throttle channel.

I have scrutinized all parameters many times, there are NO parameters (except the above) related to my 2 problems,
ie, no yaw servo movement in response to rudder stick, and no gyro response to vehicle movement.

Anyway, thanks for your help.