Servers by jDrones

SingleCopter & CoaxCopter Support


(Christopher Gehrich) #101

Thanks a lot @Leonardthall!

I’ll try it out this afternoon.

Edit: Firmware loads ont the PX4 Mini just fine!


(Christopher Gehrich) #102

Motors aren’t starting when I arm. Do I have to go through the mandatory hardware ESC calibration after every new flash of the controller? I know the ESCs are calibrated from the last time I flashed. Servos are working well though.

Edit: Figured out why the motors were’s turning. Forgot to arm the rig using the transmitter after using the button on the PX4. Gotta do both!


(Christopher Gehrich) #103

@Leonardthall
Ok. New problem. The dualcopter is not correcting Yaw error in the correct direction. Instead, it is causing a positive feedback loop. Reversing the RC channel doesn’t help.
See this video for an example. https://www.youtube.com/watch?v=J2NKej7eixQ


(James Pattison) #104

Ave you tried just switching the esc’s around on the output rail?


(Christopher Gehrich) #105

The ESCs dont affect the servos. My servos are twisting the wrong way for yaw, so switching the escs wouldn’t change that.


(James Pattison) #106

Ok, sorry. Dual copter uses differential torque for yaw. You’re using single copter with two motors then?


(Christopher Gehrich) #107

My rig is using four servos and it is dual copter. It was just easier to set up due to the flap positions.
If dualcopter firmware uses differential torque to yaw, why do the flaps react to my yaw stick input?
My channel 5 is top clockwise motor. Channel 6 is bottom counter-clockwise.


(James Pattison) #108

The esc’s should be on 3 and 4 I think, with servos on 1 and 2. Use a y lead for the servos, or map 5 & 6 to 1 & 2 in Params.
Or load the singlecopter firmware, with servos ch1-4 and esc’s on 7 with a y lead (or remap).


(Leonard Hall) #109

Hi Fragmaster,

You have loaded single copter instead of coax copter. So you will find you have identical throttle control. Using the configuration you are able to swap between single and coax copters and only adjust the yaw pids.

If you want to continue to use single copter and flap actuated yaw rather than throttle/torque actuated yaw you will need to fix your servo order.

You simply need to switch the two elevator servos and the two roll servos. This will swap yaw but keep roll and pitch the same.

Let me know how it goes!!

The copter looks good!!


(Christopher Gehrich) #110

Thanks Leonard! Can you compile the PX4 version of CoaxCopter for me like you did for single copter?

@Leonardthall


(Leonard Hall) #111

Hi Fragmaster,

You should be able to load it using mission planner now. Just go to the Beta version.

let me know if you have trouble.


(Christopher Gehrich) #112

I don’t see an option for coax copter after clicking “beta firmwares” in mission planner. I just updated MP, so I think all is ready. I see rover, plane, quad, hex, x8, antenna tracker, heli, tri, y6, and octa.

@Leonardthall


(Leonard Hall) #113

Hi Fragmaster,

Sorry about that!! I didn’t realise you couldn’t use mission planner!!

Here is a link for Coax Copter:

And for those looking for single copter:


(Christopher Gehrich) #114

Thank @Leonardthall, but I need the V1 of the firmware to run on the PX4 like when you linked to the singlecopter firmware on August 5th. Can you do that?
I get the “Firmware not suitable for this board” error when I try to install the coax firmware that you just linked here.


(Leonard Hall) #115

Hi Fragmaster,

Sorry about that, here are the V1 files

Here is a link for Coax Copter:

And for those looking for single copter:

let me know how you go!!


(Christopher Gehrich) #116

Umm… @Leonardthall ? These are the same links as before.
:sweat_smile:


(rmackay9) #117

Maybe these will work:

single: https://dl.dropboxusercontent.com/u/3852647/AC34/ArduCopter-v1-single.px4
coaxcopter: https://dl.dropboxusercontent.com/u/3852647/AC34/ArduCopter-v1-coax.px4


(Leonard Hall) #118

Sorry, I picked the wrong two.

Looks like Randy has you covered.


(Christopher Gehrich) #119

Thanks @rmackay9 ! Those are the files that I need. However, I cannot download from those links because they automatically open as new tabs and display lots of text. dl.dropboxusercontent.com can be a bit troublesome with these .px4 and .bin files. Could you please share zip file that contains both versions like you’ve done in the past? Also, www.dropbox.com links worked for @Leonardthall without an issue.

Thanks a lot!


(rmackay9) #120

Fragmaster,
Ah, ok. Maybe this link to a zip which has both firmwares in it:
https://dl.dropboxusercontent.com/u/3852647/AC34/ArduCopter-v1-single.zip