Servers by jDrones

Single copter help

I have recently started working on a single copter and all the frame types are set properly and all hardware is installed but when I throttle up all 4 servos move too, how do I get them not to react to throttle

Is it just sitting on the bench? Perhaps it’s just stabilizing action.

Do all servos move in one direction? As if to yaw the copter? I have not played with singlecopter for many years now (and not with arducopter), but it will most likely be some kind of feed forward for throttle/yaw compensation.

Hello it’s all sorted now, However the new problem I have is the roll control, its supposed to be 1 and 2 that tilt for the roll and it’s just 4 that turns, how can I fix this

the roll action is done with 1 and 3 as described here : https://ardupilot.org/copter/docs/singlecopter-and-coaxcopter.html

Is your copter armed ? because you do not need to arm it to move the servos 1234 to perform the roll/pitch movement with your radio (you do need to arm it to perform the yaw and thrust movement)

Yeah I arm, it and i got it wrong last time it’s the yaw that doesnt work, for the yaw the 4th servo is the only one that goes and does anything, and then for roll its backwards so the 2 and 4 tilt slightly.

Also when I throttle up 123 do exactly what they should be doing if they were in yaw but I’m throttling up not performing yaw

Heres a video of what happens, https://youtu.be/wsOFaj3urLE

Does roll and pitch work (or the servos respond) when not armed ?

You already said you’ve set the frame type, but I just want to be sure, have you set FRAME_CLASS in the “Complete Parameter List” to 8

Yeah I have frame class at 8 and frame type at zero.

Does 1 and 3 move like they should when not armed ? by pushing your stick to the left or right ?

Same for 2 and 4 with your stick back and forth ?

No nome of them move, could it be the firmware,
I tried the quad firmware and it worked it just didn’t have yaw or auto stability

they dont even work when unarmed they dont recieve anything from transmitter

is the transmitter working properly then ? roll and pitch are moving in the radio calibration pannel when you move your stick ?

oh yeah that’s possible, I don’t recall exactly what I selected when launching ardupilot for the first time (I’m not home currently, I can’t check).
I remember selecting Arducopter (arduplane, ardurover and ardusub where also on the list) and then I had a choice between two things “something” and “heli-something”. “Heli-something” was not the right one.

If it’s what I think it is, you should use the “something” (“quad firmware” as you said,could be the name, but I’m not 100% sure, that’s base on my memories) and not use the “heli-somthing”.

I found a screenshot. It could be different on your board but here I select Arducopter and NOT arducopter-heli.

How did you get that up

https://1drv.ms/u/s!AkqQiRKhTxPzg0ze05h-EodZ6yNa
What one of those shall I pick

Also are you using mission planner for it

You flash Copter and then configure FRAME_CLASS for the craft geometry you have. In your case Single Copter (8), then the defaults for that Class will populate. But surely you have done this already?

I’m not sure about flashing, how do you flash in ardupilot.
Also I have done the frame type 8 before.

Servers by jDrones