Simulation in Mission Planner Complaining About Missing DLL

I am using mission planner 1.3.79 ArduCputer v4.3.2 on Windows 11. I was trying to run ArduCopter simulation from the simulations tab on Mission Planner. After clicking on simulation tab, I selected the “Model” then clicked on Multirotor logo under “Please select a firmware to run”. This always gave me a popup saying “ArduCopter.exe - System Error”.
“The code execution cannot proceed because cyggcc_s-seh-1.dll was not found. Reinstalling the program may fix this problem.”

I tried reinstalling Mission planner a couple of times but nothing worked. I kept getting the same error.

SOLUTION:

I search for the file “cyggcc_s-seh-1.dll” in my cygwin64 installation directory by using windows search. It found the file and I copy paste this file to the directory containing “ArduCopter.exe”. Now everything is working fine!

2 Likes

hello, I have the same problem as you, but the files you mentioned are not available to me. Can you write more clearly?

You will have to install Cygwin (if you haven’t already, better not to install this in C drive) from here: Cygwin Installation

This installation will create a directory, search for the missing .dll file in the cygwin installation directory. It should be present there. Copy the file, then find out where ArduCopter.exe is located. This can be done by typing ArduCopter.exe in the start menu and right-clicking on it to get the “open file location” option.

Now paste the copied .dll file into the same directory where ArduCoper.exe is present.

https://firmware.ardupilot.org/Tools/MissionPlanner/sitl/
just install from there and paste in stıl plance then run, youre welcome :smiley:

1 Like

Thanks. I was dealing with this problem for 4 days, finally it got resolved.

1 Like

1.- Descargar el archivo “cyggcc_s-seh-1.dll” del siguiente link:
https://firmware.ardupilot.org/Tools/MissionPlanner/sitl/
2.- Pegarlo en la siguiente dirección:
C:\Users.…\Documents\Mission Planner\sitl
¡Problema solucionado!

1 Like