Servers by jDrones

Sim_vehicle.py and MAVROS not communicating

I am trying to connect a MAVROS instance to my working sim_vehicle.py instance. I know it works because I can issue commands, read data, etc. in QGC.

The issue I’m having is that MAVROS isn’t connecting to the sim_vehicle.py UDP port. I have tried
roslaunch mavros apm.launch fcu_url:=udp://127.0.0.1:14551@
and I get an error when I run
$ roslaunch mavros apm.launch fcu_url:=udp://127.0.0.1:14551@14550

[ INFO] [1592909678.730113628]: Plugin wind_estimation initialized
[ INFO] [1592909678.730154999]: Built-in SIMD instructions: SSE, SSE2
[ INFO] [1592909678.730184699]: Built-in MAVLink package version: 2020.6.6
[ INFO] [1592909678.730206499]: Known MAVLink dialects: common ardupilotmega ASLUAV autoquad icarous matrixpilot paparazzi slugs standard uAvionix ualberta
[ INFO] [1592909678.730230708]: MAVROS started. MY ID 1.240, TARGET ID 1.1
[ERROR] [1592909678.818515098]: udp0: sendto: Invalid argument
terminate called after throwing an instance of ‘std::system_error’
what(): Resource deadlock avoided
================================================================================REQUIRED process [mavros-1] has died!
process has died [pid 15984, exit code -6, cmd /opt/ros/melodic/lib/mavros/mavros_node __name:=mavros __log:=/home/vagrant/.ros/log/ba9f5e10-b536-11ea-9c79-02fc382c427e/mavros-1.log].
log file: /home/vagrant/.ros/log/ba9f5e10-b536-11ea-9c79-02fc382c427e/mavros-1*.log
Initiating shutdown!
================================================================================
[mavros-1] killing on exit
shutting down processing monitor…
… shutting down processing monitor complete
done

I have also tried various other ports that show up on the screen for the sake of trying.

I launch sim_vehicle using
sim_vehicle.py -v ArduCopter -f gazebo-iris --use-dir copter0 -I 0

Many thanks in advance!

Hi @iwishiwasaeagle,

I think the fcu_url is already written in apm.launch
I have this: arg name=“fcu_url” default=“udp://127.0.0.1:14551@14555”

Have you tried without gazebo?
For me it works without gazebo, but not with gazebo-iris.

Servers by jDrones