Setting my GCS, troubles with arming

Hello guys,

TLDR; I am trying to set up my Pixhawk Cube-powered quadcopter with one 2.4 GHz radio and RFD900 sik telemetry radios to use as a ground station. The link is good. But when the RFD radio is connected the quad won’t let me arm and fly.

More details:
The software running on the quad is ChibiOs, arducopter if I understand correctly. The mission is planned and the quad is on the ground, powered and ready to go. When both 2.4GHz radio and RFD900 are connected at the same time I am unable to arm and proceed with the mission. As soon as I disconnect the RFD900 I can normally arm with the 2.4Ghz radio as I would usually and everything works as expected.

I also tried one thing. I tried to arm and take off using the 2.4GHz radio in loiter mode. Once airborne and hovering a few meters above the ground I connected RFD900 and then the quad (probably still in loiter mode) lost power and almost crashed, landed, and disarmed. Almost like if you’d suddenly lowered the throttle all the way down in loiter mode.

I don’t know what is happening. Clearly this must be some kind of issue related to settings. Could somebody steer me in the right direction? I have a feeling there must be a setting telling the copter who is the master radio link and who overrides who. But I was unable to find it.

Do you power RFD from a separated 5V power instead of the telemetry port ?
Also send log files.

Hello @Eosbandi and thank you for your input!

  1. No, I do not power the RFD from a separate source. And I know I should. I use Pixhawk Cube to power it, but that should be okay because I lowered the Tx output power to under 17-20dB for short-range testing (thats is under 100mW while the radio is 1000mW capable). So this is not the issue I believe.

  2. The log is available here
    It shows the scenario when I was able to arm the quad with RFD900 unplugged from the computer. I re-plugged it when the quad was maybe 2-3 meters above the ground in loiter mode. You should see it from the log file. But I still have been unable to find the culprit …

Log shows that throttle channel is indeed lowered to min. Could it be RC_OVERRIDE through the RFD radio ?

Ok, it looks like the problem was something similar. In QGroundControl there is a setting “virtual joystick” and I had no virtual joystick plugged in, so the input there was throttle 0. The copter’s system takes preference from the RFD link …

Well, I disabled the virtual joystick and now it looks like the problem is solved. Many thanks!