Set up the Building Enviroment

When I run:
git submodule update --init --recursive.

I got:
error: pathspec ‘–-recursive’ did not match any file(s) known to git.

When I run:
./waf configure –-board CubeBlack

I got:
No function ‘\xe2\x80\x93-board’ defined in /home/mpbatista/pitangus/wscript

I’m working in a forked version, but it is an issue even when I clone the master one.

are you running the commands inside the ardupilot directory?

Yes, I am running inside the clonned directory. I’m working in a WSL enviroment into ubuntu installed in Windows.

Could you please provide the entire terminal output as an image or text?

1 Like

mpbatista@ENG-MARCOSBATISTA:~/pitangus$ git submodule update --init –-recursive error: pathspec ‘–-recursive’ did not match any file(s) known to git.
mpbatista@ENG-MARCOSBATISTA:~/pitangus$ ./waf configure –-board CubeBlack Setting top to : /home/mpbatista/pitangus Setting out to : /home/mpbatista/pitangus/build Autoconfiguration : enabled Setting board to : sitl Using toolchain : native Checking for ‘g++’ (C++ compiler) : /usr/bin/g++ Checking for ‘gcc’ (C compiler) : /usr/bin/gcc Checking for c flags ‘-MMD’ : yes Checking for cxx flags ‘-MMD’ : yes Checking for need to link with librt : not necessary Checking for feenableexcept : yes Checking for HAVE_CMATH_ISFINITE : yes Checking for HAVE_CMATH_ISINF : yes Checking for HAVE_CMATH_ISNAN : yes Checking for NEED_CMATH_ISFINITE_STD_NAMESPACE : yes Checking for NEED_CMATH_ISINF_STD_NAMESPACE : yes Checking for NEED_CMATH_ISNAN_STD_NAMESPACE : yes Checking for header endian.h : yes Checking for header byteswap.h : yes Checking for HAVE_MEMRCHR : yes Checking for program ‘python’ : /usr/bin/python Checking for python version >= 2.7.0 : 2.7.17 Checking for program ‘python’ : /usr/bin/python Checking for python version >= 2.7.0 : 2.7.17 Source is git repository : yes Update submodules : yes Checking for program ‘git’ : /usr/bin/git Checking for program ‘size’ : /usr/bin/size Benchmarks : disabled Unit tests : enabled Scripting : enabled Scripting runtime checks : enabled Checking for program ‘rsync’ : /usr/bin/rsync ‘configure’ finished successfully (2.323s) No function ‘\xe2\x80\x93-board’ defined in /home/mpbatista/pitangus/wscript

I think something is wrong with the - s.
git submodule update --init --recursive
Does the above work?
Also, do
./waf configure --board CubeBlack
You have a mismatch at “–” and “-”

1 Like

Oh thanks so much! You really helped su much. I still have a problem with submodules. Related to configure, I got it and now I’m able to upload in pix. I run and I got it:

mpbatista@ENG-MARCOSBATISTA:~/pitangus$ git submodule update --init --recursive fatal: No url found for submodule path ‘modules/PX4Firmware’ in .gitmodules

In my .gitmodules I have:

[submodule “modules/uavcan”]

path = modules/uavcan

url = git://

[submodule “modules/waf”]

path = modules/waf

url = git://

[submodule “modules/gbenchmark”]

path = modules/gbenchmark

url = git://

[submodule “modules/mavlink”]

path = modules/mavlink

url = git://

[submodule “gtest”]

path = modules/gtest

url = git://

[submodule “modules/ChibiOS”]

path = modules/ChibiOS

url = git://

[submodule “modules/libcanard”]

path = modules/libcanard

url = git://

Did you run git submodule update --init --recursive command inside the ardupilot repository folder?
Do cd ardupilot/ before executing the git submodule update --init --recursive.
Above is valid for building ardupilot main repository from source code since I don’t know which forked repository you are using.