SERVO12 Gimbal Tilt not working - Resolved!

I had given up on this with copter 3.4 and 3.5, so thought I would give it another try with my HK Pixhawk, 3.6 and ChibiOS. I am trying to set up a tilt servo for use with a spotlight. No matter what I try, the servo won’t move. Have tried this on a Pixhawk Cube 2.1, PixRacer and Pixhawk with the same result. Works fine when connected to the receiver. Any thoughts or guidance would be appreciated.

1 Like

If it’s simply for manually tilting set a SERVOx_FUNCTION for the Rx input channel you want to use. The attached would be for AUX1 output (chan 9) and then choose whatever input channel you have configured as the parameter value.


Thanks Dave. I really need the angle of the gimbal to adjust based on the attitude of the aircraft. I tried a value 62 “RCIN12” - which should have duplicated the output from RC12 - but no joy. I have tried 4 different types of servos to eliminate the possibility of a bad servo.

I just tried this again on my Pixhawk Cube 2.1 - AC3.5.5 RC1 running Nuttx and the same issue as before, with the servo 12 option as either “7” (Gimbal Tilt), or “62” (RC12 Passthrough) - no servo movement.

I think the MNT_DEFLT_MODE should be set to “3”. If that doesn’t work could you post a dataflash log file? I.e. a .bin log file. If the vehicle isn’t armed then it’s best to first set LOG_DISARMED = 1 so that it logs while the vehicle is disarmed.

I don’t know what is up, but with that option my logs are 0 bytes in length with log_disarmed = 1 so I can’t upload them. Going to try setting log_disarmed = 0 and arming the vehicle.

I orginally started with MNT_DEFLT_MODE as “3”, RC Targeting and started switching around to see if something else would work.

Quad with HK Pixhawk, AC3.6 ChibiOS

2018-11-04 22-01-44.bin (333.1 KB)

Hexa with Cube 2.1 Pixhawk AC3.6 ChibiOS (Upgraded from AC3.5.5 Nuttx to see if that would resolve the issue. I don’t know how I ended up with two logs.

2018-11-04 21-48-30.bin (353.5 KB)
2018-11-04 21-37-59.bin (808 KB)


Re the issues with the mount, it looks like the output from channel 12 (on the flight controller) is changing with the attitude of the vehicle.

From looking at the POWR.VServo message it looks like the rear servo rail may not be being powered. I guess you’ve got a BEC or ESC powering the Pixhawk’s servo rail? Anyway, it might be good to check the rear servo rail’s voltage if you haven’t already.

It looks like the receiver input on channel 12 isn’t working though. RCIN.C12 is just a flat line at 1076 PWM.


Thanks for pointing me in the right direction. At work, I call this a “layer 0” problem - namely an error on the part of the tech. I had connected 5 volts to the rail at various point in time, but my guess is I had some other setting wrong so it didn’t help with trouble shooting.

I have successfully tested servo gimbal output on the following FCs:

Pixhawk Cube 2.1, AC3.6 ChibiOS on a Hexa
Pixhawk, AC3.6 ChibiOS on a Quad
PixRacer AC3.6 ChibiOS on a Quad
PixFalcon AC3.6 ChibiOS on a Quad

Thanks again.


1 Like


Excellent, glad it’s sorted and thanks for the feedback.