Servo Output Settings

Hello,
Trying to get servo function from speedybeef405v3.
I have it hooked up to S9 for signal and just a 5v and G.
Servo is tested for operation and works on another device.
Connected to the FC i can’t make it work at all.
I even added power directly to servo by using a splitter and removed v+ to avoid frying anything on FC. The G and Signal remained.
Channels5-9 are PWM.
My switch on the tx controls the aux function within the MP correctly but nothing from the servo.
I can’t figure out which channel corresponds to which servo output. Or, how the FC knows which servo to output on.

If you wanted to control Servo5 output with a Chan7 mix on your radio for example then:
Servo5

But based on those messages it looks like you have a mess there.

Yeah it’s a big ol’ mess.
I have saved my config and started from scratch to try and eliminate some of the errors i made along the way whilst troubleshooting.
Now that I have recalibrated the RC, the servo output for channel9 has defaulted to neopixel1. this isn’t unexpected because I believe this board uses s9 for the LED’s but also can be used for driving a servo I am led to believe.
Anyway, i have the switch working and outputting the values to servo output as siggested on servo 9 from rc10in. but still no output to servo. I will try and resolder it to see whether it helps.

I resoldered the servo to S9 pad along with ground and 5v. No output, nothing, nada.
I’ve been using the drone with the TX and dropping payload servo with a switch, but I really want to get this working for automated missions.
I’ve checked and the servo has 5v supply to it, but I don’t have any scope to check the PWM on the signal wire.

Anyone able to look into my config and see what’s up? Appreciate for any help.
8July24.param (19.1 KB)

1 Like

For anyone considering servo on this FC, S9 is a waste of time at current. M5 pad worked instantly.

I had the same flight controller and the same issue. thought i was losing my mind. What kind of servo are you using. now mine spins but wont stop. PWM on servo output page gets locked to either 1100 or 1900 and will not stop rotating in either direction depending on switch setting.