Servo Movement With No Power Applied! [SOLVED]

New Cube Orange Plus autopilot and sensors. Was using 4.3.7 for described flight, I have not loaded 4.4.0, VTOL airframe, well tuned, tested stall speeds and has had 4 flights.

What’s happening: I power up the bird and let the autopilot fully boot. I can then pick it up and when I move it through level to nose down the elevator servo moves. It’s not full smooth motion, it’s jerking to one position to another to full deflection. There does not seem to be a pattern to where it winds up. I can also move the elevator by hand and I can FEEL the servo (which has no power applied) resisting my motion.

  1. It’s a new servo and I could not find any fault with the originally installed servo.
  2. I unplugged the installed RFD900 so it had NO power and this still occurs.
  3. There is nothing emitting any radiation once the RFD900 is unplugged.
  4. The aircraft is not armed via the hardware safety switch OR the software safety.
  5. NO power is getting to any servo and only the elevator is showing this problem.
  6. Moving the elevator servo to another channel (along with changing the servoX function parameter) does not solve the problem

WTF is it??

SOLVED: This particular airframe has had a weakness in its design. On the right hand side, inside the carbon fiber tube, there is a male/female barrel type connector that connects the elevator servo to the fuselage. I know the design has been improved but apparently it still has problems. If the tail section is not precisely joined and screwed in just right a very small gap is made. When the bird spools up (all four motors) the amount of vibration increases significantly. The making and breaking of connection that this vibration induces causes the signal wire to receive a voltage which is then interpreted by the servo as a move command. The fix is to test the connection by trying to induce (by hand) servo movement.

This one was tough to figure out.

You say you power up and let the autopilot boot then you also say no power applied?
Is there a bec powering your servo + rail? Is it armed? What mode is fc in?
Does the servo move properly in manual mode? And in fbwa mode for instance on the ground?

Is the servo wired correctly to the +,- and s terminals of the auto pilot?

Black wire is on top for all servos connected to the autopilot.

Main power comes from the flight battery, it is split. One connection goes to the Castle Creation’s Pro BEC (which supplies 5V to the servo rail of the autopilot) and the other split goes to a power distribution board (which goes to everything else).

When I say no power that’s not correct, the servo is getting 5V but without a control signal from the autopilot the servo “acts” as if it has no power. You can manually move the flight control surface with no resistance at all, hence “no power”.

Autopilot is not armed, not the safety switch that is mounted to the airframe nor on my laptop via Mission Planner. Flight mode on bootup is QLoiter.

In manual mode the servo behaves perfectly. All of them respond correctly. BUT, if you pick up the bird and move the nose up and down the elevator (and only the elevator) will move WITHOUT a control signal being sent to it (because it’s disarmed completely).

In FBWA mode the surfaces behave as expected except that at some point the elevator will move to a full pitch up position after the bird has taken off in a hover by a few feet.

See video here.

Found another clue: Attaching another new servo directly to the autopilot servo rail has, so far, been immune to this problem. I think this means there is a bad connection in the right hand side tail boon which this aircraft has had issues with in past versions but was supposedly fixed in this version. I don’t have a way yet of checking what that bad connection could be as it’s sealed up in a carbon fiber tube.

Yeah this sounds like some sort of PWM noise or electrical issue. I imagine the movement while you move the aircraft is just coincidental to some bad connection internal to the tube - not actually any weird commands being sent by the autopilot.

Often a servo will move a bit when it is first powered even without a pwm signal, so an intermittent power 5v connection may make the servo step itself in one direction, and the tilting of the airframe may be putting some stress/movement in the plugged connection in the airframe causing the servo travelling