Servo jitter In Plane 4.0.6, but only when R/C TX active

Hardware: Matek F405-wing
FW: Arduplane 4.0.6

Servos jitter in manual mode. Servos jitter in auto modes. Jitter disappears when I turn off the transmitter. Jitter reappears when I turn it on.

Please ignore Taranis beeping about bad terrain. Also please ignore the reversed elevator.

Hi Ari,

Have you tried different versions of Arduplane to tie this issue to 4.0.6?

I’ve seen this kind of jitter in the past when the antennas of a telemetry RX are placed close to the servo leads, causing interference. In those instances, turning off the TX stopped the jittering because the RX was no longer transmitting telemetry back to the TX. Try moving your RX antennas away from your wiring and see f the behavior changes.

I’ve also seen this with the SiK radios.


What kind of receiver? 900MHz?
I see a black antenna in the fuselage.

This is an mRo 900MHz radio. I tired unplugging it, and the jitter continues. I tried unplugging the telemetry part of the FrSky receiver, and the jitter continues. The only time the jitter stops is when I turn off the Taranis, or when I unplug the SBUS cable between R-XSR and the F405.

I have no indication that this is specifically a 4.0.6 problem or an F405 problem. I mention them to give a fuller picture of my setup.

This is my 4th ArduPlane airframe, second with F405 (other two are PX4-minis). This is the first time )'m experiencing this problem.

So you identify what’s this ! May be you are on bench and ground antenna on your taranis / xsr antenna too close. Try moving taranis farther. Which antenna do you have on taranis and xsr ?
You could try carrefully shielding xsr with aluminium or copper foil (no contact between pcb and foil should be made) Or try to reproduce a faraday cage with other materials to isolate problem


Unplugging the telemetry cable between the FC the RX doesn’t stop it from transmitting. It will still report back remote RSSI (and maybe receiver voltage?) with no external telemetry sources. I’d recommend temporarily relocating these antennas away from the FC and cabling to troubleshoot the issue:

You may even be able to observe a change by putting your hand on them.

Exactly! The only time jitter stops is when the RX isn’t talking to the FC, either because the TX is off, or because the RX’s power-and-sbus connector is unplugged.

Hi Ari,
Have you tried an older fw like Plane 4.0.5 or Plane 3.9 just for debugging purposes?

Thank you for your suggestions. It’s 100% interference from the 2.4GHz RC RX. Moving it around changes the jitter response. Holding the antennas in my first stops the jitter.

The bad news is I can’t find a good place the these antennas. Some jitter seems to remain wherever I place them. The good news is that these are cheapy no-name servos from Amazon. Almost none of the other servos I have in different sizes, Hitec, Futaba, JR, even Turnigy, have this response. Some of the older Futabas jitter a tiny bit, but nothing like this.

Anyone have recommendations for reliable “9-gram” servos?

Emax es08 mg servos are good, reliable and cheap.

Thank you for the recommendation!