Sensor loss message from FrSky Telemetry on Kakute F7

Getting “sensor loss” audio message from Taranis X9D Transmitter. The flight controller is a Holybro Kakute F7 (not the AIO). I have Flightdesk installed on Taranis and all worked fine when I was using the TX of UART 1 connected to the S.port of a XSR but noticed in the following that I could use the TX of UART 6.

Now UART 6 is also used for the S.bus but only the RX side. I do have the following set


and like I said when I was using SERIAL 1 it worked fine so I am wondering if having both telemetry and Sbus on the same UART is too much.

Firmware is V3.7.0-dev

I should add when displaying the telemetry sensors on the Taranis I do see traffic for a short time but then it just stops on all the detected sensors from the flight controller.

I have a similar configuration on a couple of builds and it works fine. I use yaapu not Flightdeck, but should be the same, and my receiver is an R-XSR.

I’m not sure if it is necessary, but I specified the baud rate as 57600.

In bench testing, “sensor lost” usually means the transmitter is too close to the receiver.

It looks like you were right. After moving the S.port wire to UART 6 I was bench testing with the Taranis far to close to the XSR. I should have know that was the issue. Thanks for your help.