Sending Realsense T265 data pose with Dronekit command at the same time

Hi guys, i need your help
I’m currently working in a Multicopter Indoor’s Project. It’s using Intel Realsense T265 as Navigator, Raspi 4B(work with T265) and 3B(work with dronekit) as a companion computers and pixhawk (Arducopter) as the FCU. Raspi 4B connected to Telem 2 FCU by FTDI and Raspi 3B to FCU by USB port. While Raspi 4B send T265 data pose to FCU, it works fine. While Raspi 3B send dronekit command, it works fine also. But when i send T265 pose while send dronekit command, i get error. Can somebody give me a suggestion or something? I’ll post this problem to ardupilot issue too. Thanks guys!

Hi, I encountered the same problem as you, how did you solve it?
I want to use dronekit to control drone flight while T265 is navigating. It is normal to start the T265 and dronekit scripts separately, but if you run dronekit after T265 is running, an error will occur and the dronekit cannot communicate with the flight controller correctly.
thank you!

Why 2 CC ?
I cannot understand why you need so much hardware as the Pi 4B has enough power to implement additional functions.

sorry for the late reply,
i was stuck in this issue for 3 months and i can’t get any solution. Either you’re using 2 companion computer, changes the port, change the baudrate, change the parameter, it still won’t work. How about your progress and observation? i’m really glad to hear that

actually yes, Pi 4B 4GB is enough to do those function. But it results the same error. So i’m trying to do it with 2 CC, but the same error still come. Maybe you guys can give me some advice. I’ve tried any possible solution but the same error still happen. Thanks for the suggestion btw

Hi,I haven’t made any progress yet. I consulted in the forum and did not receive a useful reply:
I found some similar discussions:
but the problem still exists.

Btw thanks for the reference. I might want to try APSync and follow some advices from those discussion. Actually, last year my team succesfully combine the T265 and Dronekit, they already did the auto-waypoint and dropping-payload mission. But it’s been a year ago and we forget to make the documentation. So we totally forget about it.

Okay, if there is any progress, please let me know, thank you very much!

Actually yes. I’ve try building dronekit-pymavlink library from the source and the program works (the error message still there but my program can change mode and arming the drone). Try to uninstall the dronekit and pymavlink from the pip first (sudo pip uninstall ), git clone the dronekit repo, build and install it. Today i wanna try to doing it from different CC (Raspi4b for T265 and Raspi3 for dronekit). Also i wanna try to using pymavlink connection, instead of dronekit, (according to: I’ll let you know my progress tomorrow

I’ve tried it and i only can arming the drone succesfully. Changing the mode sometimes success and sometimes not. I’m still looking forward for a better solution