Servers by jDrones

Secand GS Serial problem on ArduPlane-4.0.5

Hello,
I have upgrade Pixhawk v2 to ArduPlane-4.0.5 but when i test serial (2,4,5) as mavlink. I have a problem that , the serial has high latency and very slowly ,some time the serial stoped . I have reset the GS many times.
I have checked serial protocol to β€œ1”. baud-rate to β€œ57”.
does boot-loader effects or it is a code bug? :face_with_raised_eyebrow:
When i have test ArduPlane-3.9.8 every thing is OK. :grinning:
any suggestion.
best regard,
Raj M.Raj

Question are you testing in side ?

The Autopilot is test in side .only I connected the power module and two TTL–>USB.

are there any Modems plug in
when i am testing in side turn it down to 1 mw

No there is no modem connected to it ,gust USB to TTL .

are you only using TX and RX and the ground ?

yes, and i record the two GS .

There is a patch in the current Plane beta to address an issue matching
this description.

As a workaround, you could look at raising SCHED_LOOPRATE

1 Like

Thanks a lot,
I has raised the SCHED_LOOPRATE from 50 to 250 and the problem has gone .
but when i read the documentation of this parameter they wrote:

This should only be changed by developers

Does it has any other effect?

Sadly, we do have reports of it affecting flight behaviours - it really
shouldn’t, but there are certainly reports of them being there.

tridge has released another Plane beta today, so hopefully not too long
before you won’t need to fiddle this parameter.

Peter

1 Like
Servers by jDrones