SDP33 Airspeed sensor data unhealthy


I’m having issues setting up the Drotek Sensirion SDP3x Airspeed sensor. I’m getting Airspeed unhealthy in Mission Planner, and the airspeed data hovers around 0.01 m/s in no wind, but does not increase when I blow on the pitot tube. Today, without making any changes, the unhealthy warning went away but I’m reading zero airspeed.

The sensor is plugged directly into the Pixhawk’s I2C port and is the only device on the bus. I double checked the GND SDA SCL VCC wiring order and is correct. I used the cable that came with the sensor. I’m using a pitot tube and double checked the ports.

I’ve read these discussions on the sensor:

I’ve tried all the suggested parameter settings without luck. I also tried ARSPD_BUS 0,1,2, ARSPD_OPTIONS 0 and 11, ARSPD_TUBE_ORDER 0,1,2, none of which worked.

I’m also seeing the sensor on the HW ID tab, but bustype UNKNOWN where it should be I2C.

For now, I’m swapping the sensor out with my old 4525D airspeed sensor from HolyBro which worked in the past, but I’m hoping to get the SDP33 working for the increased low-speed accuracy.



ArduPlane 4.3.4

Airspeed parameters:

Full params:
params_03_14_2023.param (17.3 KB)



Found the problem in this Github post:

Setting ARSPD_BUS to 3 fixed it on my Pixhawk.

1 Like