S.PORT and F.PORT not working in Beta5

Hello @rmackay9, I am not able to connect the radio to MatekH743-Wing, using FrSky S.Port. It cant decode the S.Port and also the FrSky S.Port Passthrough telemetry is not working. I tried the Heli latest dev version and is also not working. It also doesnt work in the Heli FW version without Bdshot. If I load the Heli Stable 4.0.7 its working. Before loading different FWs I always do Mass Erase before flashing using the ST32 Cube programmer. Something is wrong with the RCIN. If I set the SERIAL7_PROTOCOL=10 + SERIAL7_OPTIONS=7, S.PORT Passthorugh is not working. If I set SERIAL7_PROTOCOL=23 (BRD_ALT_CONFIG=0) I have radio connection but no telemetry. If I set SERIAL7_PROTOCOL=23 + SERIAL7_OPTIONS=15, the F.PORT is decoded but just for a few seconds before setting “radio failsafe”. I use the Frsky Archer RS receiver with S.Port and SBUS_out connected in the SERIAL7. Could you please advice? Thank You!
Heli_Parameter_B5_test.param (20.8 KB)

Hi Pedro, I’m using fport on my matekh743 as well,so try with:
connect your receiver to T6

and last, in OpenTX you need to enable fport on your model setup, refer to the manual here https://www.frsky-rc.com/wp-content/uploads/Downloads/Manual/ARCHER%20RS/ARCHER%20RS-Manual.pdf

Hi @yaapu,

I am very familiar with these parameter settings. All my models have similar concept using MatekH743 or KakuteF7 all with the ArcherRs. All running with S.Port with your Yaapu Lua (congrats on the script I love it :slight_smile: ) script on the transmitter.
If I upgrade to the Heli beta5 it’s not working the S.Port and the F.Port only runs for few seconds.
Have you tried the Heli Beta5 release?
Thanks Pedro

Just tested the Dev version and the above issues are solved already! Thank you