Running APM planner on Ubuntu 14.04

Hey, Well i got APM planner installed on Ubuntu 14.04 but when i launch it and click on any button it crashes, Kindly can any one got APM planner running on ubuntu 14.04 post every single step he made and post also how to uninstall the actual running version?

hi @rayane, the apm planner should create a log file. It can be found in your home directory in the apmplanner2 Folder. Take a look - perhaps it will Point you the issue.
If not - just let me know - BTW did you install the software package or did you build it by yourself?

Thank you for the reply @Arne-W , I opened the log file and it says:

APMToolBar: updateLinkDisplay “ttyS0” : “115200” connected: false

and what concerns the software package i installed it.

Thats the only line in that logfile? Nothing else?

Ok the question was not good - so Did you build a current master or did you download a version, and what is the version you are currently using.

@Arne-W No it is not the only line in the log file, here attached you can find it

log.txt (10.0 KB)

beside this log file i have 5 others but they are empty.
I’m really new to this thing but as long as i know i built nothing if you mean the apmplanner version i’m using apmplanner2

kindly give me a further explanation if it is not what you asked for. Thank you

Your version is very old - 2.0.18 at the moment the master is 2.0.25-rc1.
Take a newer package or build it from scratch - on github you will find everything you need to build by yourself. There has been a lot of progress since 2.0.18 so I think it is worth the effort.

@Arne-W Thanks a lot. One more question Do you know how to uninstall the previous version, i searched a lot but everything wasn’t well documented.

sudo apt-get remove apmplanner2

I thought it was something big based on what i’ve seen. Thanks a lot

I tried to install it and i saw it is saying that Qt5.2.1 is no more working. can anyone show me how to upgrade Qt5.2.1 to Qt5.4.2. Thanks

Well this is what i get when running qmake

Project MESSAGE: Qt version 5.2.1
Project MESSAGE: Linux build x64_86
Project MESSAGE: Ubuntu Build
Project MESSAGE: Release flavor
Project MESSAGE: BASEDIR /home/rayane/workspace/apm_planner DESTDIR /home/rayane/workspace/apm_planner/release TARGET apmplanner2
Project MESSAGE: Using MAVLink dialect ‘ardupilotmega’.
Project MESSAGE: Skipping support for Google Earth
Project MESSAGE: Skipping support for libfreenect
Project MESSAGE: Adding ALGLIB /home/rayane/workspace/apm_planner/libs/alglib
Project MESSAGE: Skipping support for XBee
Project MESSAGE: Skipping support for Magellan 3DxWare (manual override from command line)
Project MESSAGE: Skipping support for Opal-RT
Project MESSAGE: Skipping support for Google Earth
Project MESSAGE: Skipping support for Camera View
Project ERROR: Unknown module(s) in QT: quickwidgets

check this :
There you can download an online installer for different plattforms. Download and install it. Start the installer and install the Qt Version you need. The installer should provide several Qt Versions.

I tried what you told me but it seems that it doesn’t overwrite. When I run qmake -v I get Qt5.2.1 version and the same message i posted earlier appears when i run qmake
Do you have any idea how to fix it? I appreciate you help

Try setting these two environment variables (assuming Qt 5.4.2 is installed at /usr/local/Qt-5.4.2):

export QTDIR=/usr/local/Qt-5.4.2
export PATH=$QTDIR/bin:$PATH

you mean getting the path of
I got this path /opt/qt54/bin and i tried what you told me but I still have the same message.
Can you please tell me whether is it the path of or is it another thing ! and if there is a command line to get the path! Thanks

To display the environment variables and their values you can type on the command line:
$ env
Or if you want to know what a particular environment variable (for example PATH) is set to:
$ echo $PATH

hey, again it didn’t work. when i run env these are the variables that has QT inside:


i have no idea which one to choose. Plz help

Well guys, I could make Qt5.4.2 as a default by just editing default.conf in /usr/lib/x86_64-linux-gnu/qtchooser .I just added the path of Qt5.4.2. Thanks