Servers by jDrones

Rugged ArduBoat for Mapping Applications (Continued)


(Kevin Klemens) #1

This Discussion Thread is a continuation of the original Discussion Thread, “Rugged ArduBoat for Mapping Applications”, that was originally located in the DIY Drones ArduBoat User Group.

Forgive the mess that is the control box, I’m working on trying to find a place for everything, but some of these power wires…

I got everything working with the exception of one of the thrusters and I can’t figure out why. Here’s a rundown of what my issue is:

  1. As per the Rover instructions, I have the left (port) thruster plugged into Servo1 and the right (starboard) thruster plugged into servo 3.
  2. I have skid steer OUT enabled.
  3. When I increase throttle only the right thruster rotates.
  4. When I reverse the PWM wires going to the Pixhawk, only the left thruster rotates.
  5. This leads me to believe I have an issue with RC1 PWM output. Is there a parameter I missed in my setup?

(gmorph) #2

Unlikely you have a RC1_PWM output issue. Can you attach a tlog or bin (dataflash) log file and I’ll have a look.
Check your RC1_ parameter settings to ensure you have a min max set to sensible values.
Thanks, Grant.


(Kevin Klemens) #3

Thanks Grant, I’m pretty new to ArduPilot and this is my first vehicle.

Attached are two tlog’s from today and a screenshot of my RC1 and RC3 values.

2016-06-20 18-15-04.tlog (441.0 KB)
2016-06-20 18-10-56.tlog (201.2 KB)


(gmorph) #4

Hi Kevin. Are you running the latest 3.0.1 version of ArduPilot?
Secondly you should always have the arming checks on. At the very least have ARMING_CHECK enabled as this will perform system checks and tell you if there is a problem but won’t prevent you from arming. If you also have ARMING_REQUIRE on then that will prevent you from arming but this is a GOOD thing as there is obviously a problem with the vehicle that needs solving.
The issue is with RC_MAP. Looks like you have changed it so
RCMAP_YAW = 1
RCMAP_ROLL = 4
This means you have told the pixhawk that instead of outputting the value on channel 1 its now being output on channel 4. With skid steering the output channels are RCMAP_THROTTLE and RCMAP_ROLL. You can either move your channel 1 connection to channel 4 or change back to defaults RCMAP
Let us know how you go.

Thanks, Grant.


(Kevin Klemens) #5

Wow thanks Grant for clearing that up, I got up and running for a bit today.

Yes, I’m using 3.0.1. I have a Spektrum DX8 for my radio and a Sony Xperia Z4 Tablet for running Tower. I’m running a 3DR PPM encoder for the RX.

I had a bunch of problems with the arming checks and I am not quite sure how to arm in MP, so that’s why I took them all off and I’m fine arming with just the hardware safety switch. I plan to go back and revisit as I understand the settings better.

You were totally right about the RC_MAP. I changed them back and the throttle and skid steer worked fine, albeit on odd radio sticks. I tried to change them in MP, but they didn’t seem to change after a few restarts.

I manually reversed the throttle setting on my radio. It now works as it should on the left stick.
The rudder was a bit trickier as it was on the right stick for up/down. I had to manually switch the plugs on the PPM encoder for 2 and 3, then it worked fine. Right stick-left/right.

Picture and video in Mission Bay, CA.

Next steps:

  1. I need a bigger battery. Going to go get a large 12V marine battery.
  2. Mount the sonar unit.
  3. I’d like to get rid of this DX8 Radio and upgrade the Pixhawk radio to an RFD900 and use a Logitech 310 gamepad with the tablet. What are the procedures for getting that to work with tower?

(Kevin Klemens) #6

Got out for another run yesterday with the sonar and larger battery installed.


(David Boulanger) #7

Glad your having success. Looks good.
Regards,
David R. Boulanger


(gmorph) #8

Looking really good. Nice work!
Thanks, Grant.


(Kevin Klemens) #9

Thanks @David_Boulanger and @gmorph, it’s been a fun trip into unmanned marine systems so far.

I had the USV out again yesterday trying it on AUTO mode, but had a bunch of problems…

  1. I noticed a “stuttering” on my port thruster in MANUAL mode. I didn’t have this issue when I was testing it on the bench. This may be a BlueESC hardware issue so I’m not really sure where to go here.

Solution: ???

  1. When I tried turning to port, the vehicle comes to a stop and then turns slowly to port. Skid steer works fine when I am going straight or turning straboard.

Solution:???

  1. I used Tower on my Sony Xperia Z4 tablet for my GCS because for whatever reason I was having connection issues with QGC. I wrote a simple waypoint path in Tower, uploaded the mission and changed the mode to AUTO…than the USV put it’s bow to the point, but started moving in reverse away from the point.

Solution: I have the throttle reversed on my radio. I can swap the propellers and switch the reverse on the thrusters.


(David Boulanger) #10

Kevin, I have no experience with skid steering and I use Mission Planner so I can’t help.

Regards,
David R. Boulanger


(Kevin Klemens) #11

That’s ok, I’ll try playing with it. In the very least MANUAL works so I can get my mapping project done.


(David Boulanger) #12

Kevin, You may want to try reversing what ever channel your throttle is on in your full parameter list. I think I recall others having the reverse problem your having in auto. Not 100% on that though.

Regards,
David R. Boulanger


(Arturo Sosa) #13

I had the same problem. Check the parameters of both thruster channels and change the yellow , red , and black wires around . As suggested I fixed the issue in steering mode first.


(Kevin Klemens) #14

Over the past 2 months, I did a bunch of upgrades to my USV:

  1. Replaced the 3DR Radio with a RFD900. Much better range!
  2. Replaced my T200s w/BlueESCs with stock T-200s and Bacic 30A ESCs. Fixed my port thruster stuttering issue.
  3. Used an off the shelf quadcopter power distribution board. Saved some time.
  4. Reconfigured power system to use 2x 10,000mAh LiPos in parallel for main power and an additional one for the sonar. I actually get way more run time than the large marine battery and it saves my back.
  5. Rebuilt hull mounts with stainless steel screws in addition to the marine epoxy. Nothing is breaking off this time.
  6. Currently running the Rover 3.1.0 Beta3 firmware.

Below is an example of the side scan data I am collecting after it has been edited and cropped in Reefmaster.:

Everything works fine in MANUAL, but when I put the USV into AUTO, it engages and turns 180 degrees to the course it is supposed to take and wobbles slowly in the opposite direction. See picture below:

I have tried plotting missions in Mission Planner and QGround Control and the result is the same. I have also tried reversing my thruster wires and reversing the channels on my radio, but that only yielded my USV aligning and moving backwards.

Any thoughts about what is going on?


(gmorph) #15

It looks great. Without seeing a log file my guess is your steering channel is reversed. Put the boat into STEERING mode and try and drive it around and see what happens. If that confirms your steering is reversed then assuming you have steering on channel 1 then set RC1_REV to -1 to fix the issue.

Thanks, Grant.


(Kevin Klemens) #16

@gmorph Oops, sorry for leaving off the log file, I found it and it is attached below.

Thanks for the recommendation to check out steering mode, I hadn’t thought to go there. I’ll get to it this weekend and let you know what I find out.

2016-09-17 13-45-52.tlog (826.7 KB)


(Kevin Klemens) #17

@gmorph Fixed my problem with AUTO today. I traced back all my wiring and it turns out I had my thrusters plugged into the opposite channels on the Pixhawk. Oops my mistake.

I took it out for a few hours today and although it can navigate to waypoints now, it has a pretty bad wobble which isn’t good for sidescan operations. I’m going through the documentation and trying to tune it in. Any feedback on settings for skid steer that have worked well in the past?

And about halfway through my day, I had my first engineering casualty and had to wait for the wind to blow it in…and found this…

I’ll have to work on some eelgrass thruster guards, there are some 3D printed ones out there.

Also, side note, I’m trying to ditch my RC controller and just use a gamepad that will connect to my tablet. However when I plug it in with Rover running I get a message saying that joysticks aren’t available on this firmware. Is this correct, or just an issue with QGC?


(sean d'epagnier) #18

I am very interested in what you are doing. You are scanning the bottom? Do you get depth soundings? Can you use a small sail instead of thrusters?


(Kevin Klemens) #19

@seandepagnier Yes, I’m doing side scan and single beam surveys with a Lowrance HDS-7 and TotalScan Transducer. The data is then uploaded into Reefmaster software and mosaiced. You could probably use a sailing vessel, but your control would be a lot less because you would have to tack with the wind.


(Fernando De Vidania) #20

@Kevin_K I´ve read all your posts and you´ve done a great job. I´m very interested on what you are doing and would like to do it by myself. Could you start by posting a complete list of all the items you´ve bought to do this?

Also, why didn´t you a multibeam echosounder to do multibeam surveys? (just wondering)

Again, awesome job and very interesting, thanks for sharing!