RTL thinks it already landed?

Running Pixhawk with 3.4. I want to setup failsafe, so i went outside, flew it away from me. Flicked RTL and it flew back to where it was supposed to be… But then it stayed in the air for like 5 seconds and disarmed (i suppose, all motors turned off). Crashed and broke a gimbal :frowning: - How could this happen? I’ve read that maybe it’s a broken barometer? and that it doesn’t know its altitude. Suggestions welcome.

Without logs it would be tough to know what happened.

i think this is it
1 16-07-2016 21-18-56.bin.log (90.5 KB)

Log file not very large.and it only appears that you flew this in stablize. Logs do indicate however your RTL altitude is just 5 meters? I have to guess, from the contents of this log file, that this isn’t the flight you’re talking about.

Am i not supposed to RTL on stabilize mode?

This is not the log file from the crash. No RTL in the log at all. You must of re-armed after it crashed and then shut it off. Check for other log files.


You can but in order to have RTL you have to have GPS lock.

I downgraded to copter 3.3 and changed disarm delay to 60 seconds and it worked. Not sure if the former or latter that fixed it.

Is this a very overpowered copter by any chance?