RTL did not work

I have a custom built Quad using pixhawk 4 Which i never really flew for long. Last weekend I Tried it out
Started with Stabilize, switched to PosHold then RTL. upon RTL something went bad and it drifted away until it went almost 1km and i managed to find it in a tree.
I tried to see the logs but dont really understand what to look for, maybe someone can help me please?
All i saw was gps glitch and gps-0.
Also it was quite a windy day but not too much to be unhandled by this quad I think.

Quad specs : Pixhawk 4, External GPS ublox mn8 raised on the stand.
Log file here:

Thank you

There are several GPS glitches reported in the log. Your battery voltage was very low. Your Vcc is low (what’s powering the FC?) and your vibration levels are very high with clipping indicated.

Thank you for your reply, My gps is mounted high up and everything is powered with a power module and my battery is a 3200mah 11.1v
Vibrations i noticed from the log and im assuming that its because i mistakenly removed the rubber grommets from under the FC
So this could actually be the cause?

I doubt vibration is the cause of the GPS glitch. The power module is suspect which is odd if it’s a Holybro Pixhawk 4. Also the battery wasn’t at full charge to start (assuming your voltage sensor is calibrated) and it sags very quickly. I would suspect that as well.

Battery is brand new, first flight with this battery - this one - SLS XTRON 3200mAh 3S1P 11.1V 20C + / 40C - SLSXT32003120
I might have not understood the calibration process so i might have calibrated incorrectly - will try to do that again.
Thank you very much

On the Battery Monitor page enter the voltage of the connected battery read from a voltmeter and enter it in “Measured Battery Voltage”

Thanks, I will let you know what the next test will result in :slight_smile: