RTK base with radio telemetry

I recently acquired an RTK F9P, however, I am not able to use it via radio, only with a USB cable.
Could anyone tell me the reason for this? I’m using 2 Hollybro 915MHz radios.
Could someone tell me what baudrate I have to put on the 2 radios? The one on the base and the one on the device, please?
Thank you very much.

I’m currently using these 2 settings, 1 for each radio, (base and handset).

Hello @LiqzDrone

The baud rate for the two radios are not matching, you have to use the same for both units.

I would try 38400 of Baud Rate, I think it is a standard for serial output for U-blox receivers like this.

1 Like

Also, change the Mavlink option to Raw for both units. Maybe the MAV Radio Status Messages can mess up with the GPS/RTK Inject process.

1 Like