Rpanion-Server 0.10

Hey Everyone

We’ve been facing very frequently Raspberry Pi hotspots getting “Deactivated”. Also, in recent events hotspot was deactivated and we reactivated it but, now there is no TCP connectivity.

After activating the hotspot, I connected the hotspot of Raspberry Pi and when I tried to connect over TCP from Mission Planner, it showed the message.

" A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond"

Also, I made a new hotspot network on that Raspberry Pi and tried to connect TCP on it, again this same error was shown on the Mission planner screen.

We are using Arduplane 4.3.8, mission planner 1.3.77 and rpanion-server 0.10.

The Log file of Raspberry Pi is also attached.

rpanion_log_file.txt (928.5 KB)


@Ashesh223 Connect to hotspot of Rpanion. and use in mission planner

A few things to check:

  • Have you tried connecting over ethernet? Do you get a stable MAVLink connection there?
  • How are you powering the RPi and do you have any USB devices connected? The deactivating hotspot might be occurring if the RPi is underpowered.

Are you using the released disk image of Rpanion-server or building from source yourself?

You can run journalctl --since "1 hour ago" -u NetworkManager.service on the RPi to see the network log, that should tell you why the hotspot is deactivating.

Hey Stephen

Thanks for your response.

  • Yes we have tried connecting over ethernet and USB 4G Dongle, and we are getting a stable MAVLink connection on the UDP port.

  • We are powering up RPi from external 5v UBEC through GPIO power and ground pins. We have 2 USB devices connected to it, one is a 4G dongle and another is a USB cable, but it is taking power from external UBEC, not from Rpi.

  • Yes, we are using the released disk image 0.10.

Another issue we are facing that I mentioned in the original post is, being unable to connect over the TCP port on mission planner.


So, over Ethernet, UDP works and TCP does not?

For the hotspot, I don’t know why it’s deactivating. If I can get the network log I mentioned above, I can take a look.

Yes, this is the case.

Update: The RPI hotspot has not been auto-disabled again, from the last time I activated it a week ago.

I’ve attached the network log file below.
network_logs.zip (99.8 KB)

Thanks for the log.

I can’t find anything obvious in there.

I’ve run Rpanion-server on my Pi4 for an extended period. TCP works fine over the hotspot … no stability issues.

I would recommend a bit of fault-finding:

  • Try the Wifi hotspot at 2.4 GHz, to rule out any interference issues
  • Try without the Tailscale VPN and 4G dongle, just to eliminate them as an issue
  • Try a different laptop and GCS software (QGC or MAVProxy) with TCP MAVLink to eliminate any issues there

Hey Stephen

Thanks for your quick response.

We have tried this option, by switching the hotspot at 2.4 GHz, but the results are still the same.
Also, we have tried to use 3 different laptops but, no progress.

Will try the other two options.

Currently, we are using external 5V UBEC to power up Raspberry Pi through GPIO pins.
Can you recommend any power monitoring options on the Raspberry Pi?

If you’ve got a multimeter handy, check the voltage to the Rpi when the hotspot is active. Anything under 4.8V will make the RPi unstable.

Anyone know how to set the AP’s WPA to ‘none’? I get the below error and can’t find the typical RPI conf to set that manually. I’m having an issue where one specific DDWRT based device will not connect to rpanion’s AP. It simply times out and there are no log entries showing errors etc.

Error editing network: Error: failed to modify 802-11-wireless-security.key-mgmt: ‘wpa-none’ not among [none, ieee8021x, wpa-psk, wpa-eap, wpa-eap-suite-b-192, sae, owe].

Also notice that the cpu util gets pretty topped out when streaming video at 720 60fps 8000kbps on a Zero2 W. I’m using Arducam’s IMX708 for reference.

Ok so I found the WiFiAP.nmconnection file but I’d think there’s a better way to set those parameters than editing the file directly? @stephendade any recommendation?

That looks like a bug. I’ll get it fixed up in the next few days.

1 Like

Sounds great thanks. I’ll keep an eye out for the updated image on the website.

I’ve added an update to address your issue. You’ll need to upgrade the source (see GitHub - stephendade/Rpanion-server: Web-based configurator for companion computers of MAVLink vehicles) to get it.

Ok great thanks! I’ll give that a go.

Hello @stephendade,

I am excited to explore the capabilities of the rpanion server. I have successfully flashed both my Rpi zero 2w and Rpi4 with the latest image file.

I was able to connect to the rpanion hotspot and access the web interface. However, I am encountering difficulties when attempting to connect to a WiFi network, Ethernet, or 4G dongles.

Could you kindly provide any guidance or steps to establish an internet connection? I appreciate your time and assistance.

Connecting 4G/Ethernet/Wifi will give you internet without any further configuration.

If you’re having issues, you’ll need to provide more information on what you’re doing.

1 Like

I have both Ethernet and local Wi-Fi connections, but I am unable to connect to either of them. When I use the SSID and password to connect to the local Wi-Fi network, it does not connect. I am facing the same issue with my physical 4G dongle connection.

Is it possible to connect to the Wi-Fi automatically, similar to adding Wi-Fi credentials while flashing the Raspberry Pi firmware?

Thak you for your time !

You can simply ssh into the RPi and set the networking config from there. Plenty of tutorials on the Internet for configuring that way. For reference, Rpanion uses nmcli for networking config.

1 Like

Should I use SSH through Rapanion hotspot connection?