RP Lidar A3 integration with ArduPilot

we integrated RPLIDAR A2 with pixhawk on telem1 supplying 5 volt power directly through battery via DC-DC converter. After connecting the circuit with mission planner, it responses with “PRX1 no data”, for lidar. Summarizing the issue, pixhawk and rplidar a2 are not able to communicate and send the data.
Please provide us with adequate technical support.

please post more details, schematic and parameters

params.param (17.7 KB)

Thanks for replying,

I have attached the required images and param file.

We are using pixhawk orange cube FC and trying to integrate RP Lidar A2 360.

We have provided 5v bec supply to lidar externally and uart port is plugged into telem1 port.

Parameters used for lidar is as per Ardupilot guidelines, i.e.,

serial1_protocol - 11
serial1_baud - 115
prx1_type - 5
prx1_orient - 0
brd_ser1_rtscts - 0

still in mission planner and in qgc msg displayed is “prx1 no data”
and due to this its not arming.

Try swapping the TX, RX of the cable.
Can check whether there is data in the proximity interface

Does it rotate? Looks like an A3 to me.

tried swapping tx rx but same message is displayed.
“prx1 no data”

yes after giving 5v supply it starts rotating , but I think there is some issue in data transfer, as I have also updated the lidar’s driver , and yes I checked right now that it is A3 model.

So if you can help us installing its driver and integration with cube orange.

A3 is not yet supported.

But if it gets supported it will be on the master branch.

1 Like

I agree that testing with “latest” (aka “master”, aka “4.5.0-dev”) could be a good idea but in the end, I don’t think it will work because looking at our RPLidar driver it only has enumerations for A1, A2 and S1. They are mostly the same but the startup string is different and this alone can confuse the driver.

I suspect if one of the developers had the A3 we could make it work. Or perhaps we could make a script or something to capture the first 100 bytes from the lidar.


I have discussion with Slamtec the manufacturer of RP Lidar , they said that this model is A2M12 only which is upgraded model of A2M4,

So according to that it should be compatible with our FC , but still we are unable to do that.

If anyone can check if it is possible to integrate A2M12 with Pixhawk Cube.

Ask RP lidart for the initialization string of that particular lidar. And then add that string to ArduPilot’s master branch.


Thanks for the report. I’ve added this to the 4.4 issues list but, in case it matters, I suspect this model has never worked with AP so it won’t be a “blocker” for the 4.4 release… I know you just want it to work, I’m just saying this to set expectations a bit.

I wonder if it would be possible for RPLidar to send me an A2M12… maybe I will email them. It’s tricky to fixup a driver without the hardware. It’s possible but it’s about twice as difficult.

Thanks for the reply , If you could help me knowing about the master branch setup as I am not known to it.

Hope if this issue can be resolve as soon as possible because on Mission Planner param list it is only mentioned that RP Lidar A2 is supported model. But still we are facing this issue.

If you can check by consulting with Slamtec and try its integration then please tell us the solution.

I would suggest you consider supplying component and hiring one of our developers to complete the task.

Paid development is something many corporations are willing to do in order to get their products integrated and in return it helps our community to grow.


As a side note I tried using the S1 recently outdoors and it became clear that it is very sensitive to bright sunlight. The lidar reported distances of between 1.5m to 3m in the direction that the sun was coming from even though there was absolutely nothing there. In the end I decided the S1 at least is not usable outdoors.

I get the prx1 no data warning with rplidar a3 that OP experienced with a1. Is rplidar a1m8 supported?

Not AFAIK. It would be nice if RP lidar would provide the ArduPilot project with all their lidars.


Is there any update about this issue? Has anyone been able to find a fix to make A2M12 work?