Servers by jDrones

Rover spins in circles in Auto Mode


(Stephen Bennett) #1

Hello,

I have built a rover (see attached photo) of a differential steer rover using 2 brushed DC motors.

Specs are:-

APM 2.7 (Hobbyking clone)
Motor controller is a Sabretooth 2x25
Turnigy 9x transmitter with standard firmware.
Ardurover v2.50 firmware.

The rover is working well in manual mode however when I switch to auto mode to drive to a waypoint it just spins in circles on the spot.

I have also attached a tlog of a mission. If anyone has any clues as to what the problem might be that would be greatly appreciated.

Regards,

Stephen


(Thomas J Coyle III) #2

@Tractor Pilot,
Try checking the “reverse” box next to the Radio Calibration roll bar.
Regards,
TCIII AVD


(Stephen Bennett) #3

Thanks Tom,

I have tried this (after reading posts with similar problems) However I will double check and try again.

Cheers,

Stephen


(Stephen Bennett) #4

Just a quick update.

No luck yet, I reversed to roll channel but the rover still turns in circles when in auto mode.

I have removed a steel sheet metal plate that the compass and electronics were mounted on and the orientation is much improved.

I tried to attach a file of the parameter settings however a error came up saying “The extension param is not allowed”

I have SKID_STEER_IN set to 1
and SKID_STEER_OUT set to 0

Is this correct?

Many thanks.

Steve


(Thomas J Coyle III) #5

@Tractor Pilot,
Yes, I believe that you have the skid steering parameters set correctly.

One way you can troubleshoot your issue is to put your navigation controller on the bench and run a test where you program the controller with a waypoint that is either to the left or the right of the rover and then start the Auto Mode.
You will have to have an R/C receiver tester to look at the PWM outputs of the controller to see if it is commanding the motor direction correctly or you can use the Tuning Window in MP to look at the controller servo outputs.
If you program a waypoint to the right of the controller, then the left motor should speed up and the right motor should slow down or even reverse to cause the rover to turn to the right.
If this bench test does not work as expected, then you need to determine where in the system the issue is.
Regards,
TCIII GM


(Stephen Bennett) #6

Thanks TCIII,

I was looking at the telemetry last night and will do some more analysis today.

I haven’t adjusted the PID settings from standard. This is a heavier machine than a small RC car should I play around with these settings to see if they need tuning?

Cheers,


(Stephen Bennett) #7

Hello Again,

I am still having difficulty getting my rover to operate properly in auto mode. However I am persisting and will get there soon! I can always get it to run very well in manual mode, but auto is causing me grief.

I realised yesterday that I was using the skid steer function in the APM AND the mixing mode in the sabretooth which was incorrect. However disabling both skid steer in and out and only using mixing mode on the sabretooth did not change the symptoms, it still behaves erratically in auto mode.

Question. I am using a mode 1 Turnigy 9x with standard firmware and a sabretooth 2X25. I am using the normal throttle stick (right stick no centre position) for throttle and the normal rudder stick (left stick with centre position) for steering. Should I be using the elevator stick (left stick with centre position) for throttle and the aileron stick (right stick with centre position) for steering insead?

Many thanks,

Tractor Pilot


(Stephen Bennett) #8

Hello All,

I am very happy to report that I got my Rover working successfully today.

I’m fairly sure the problem was having both skid steer mode on the apm and using mixing mode in the Sabretooth was the issue.

Anyway the Rover was able to drive to a waypoint and stop from any direction in auto mode.

You little rippa!

Cheers,

Stephen


(Thomas J Coyle III) #9

@Tractor Pilot,
Yes, you are correct. You do not use the mixing mode in the Sabertooth Motor Controller when using the ArduRover skid steering.
The Sabertooth Motor Controller should be setup to be just two independent motor controllers with left and right input from the APM. On my skid steering rovers I use the Roll joystick for steering and the Elevator joystick for the throttle so I can have forward and reverse.
Regards,
TCIII AVD


(YumaMike) #10

Hello All:
I also have the same problem with AUTO mode. I use the Sabertooth Motor Controller and the HK Thumper 6X6, APM 2.5 with Rover Ver. 2.5 installed.
I don’t have any problems in manual but switching to AUTO it spins and doesn’t go to the WAY Point.
I have tried the mixing mode in the Sabertooth Motor Controller and it works great in Manual Mode but not in the AUTO mode. When I use non-mixing mode or individual motor selection the Manual mode doesn’t work with the stick movement Up Down, Left Right movement but at a diagonal stick movement to go straight forward with forward movement of the vehicle. The Sabertooth Motor Controller works with a receiver as inputs but when using the ArduRover skid steering it doesn’t work at all. When using the ArduRover skid steering output to the mixing mode in the Sabertooth Motor Controller I get different results than when using the ArduRover skid steering.
I’m at a loss as to what I’m doing wrong and getting very flustered. I need step by step setup for this combination so I don’t have to take the chassis cover off each time I need to flip a Dip Switch and put all the electronics back on and do the calibrations again.
YumaMike


(Thomas J Coyle III) #11

@YumaMike
I have used the Sabertooth Motor Controller with an APM1.4, APM2.6, and a Pixhawk following the ArduRover Wiki instructions without the problems you have experienced.
First off how about providing some information concerning your setup:
What model Sabertooth?
What are you dip switch setting?
What is your SKID_STEER_IN parameter set to?
What is your SKID_STEER_OUT parameter set to.
How is your receiver connected to the APM receiver inputs?
What APM servo output pins are you using to drive the Sabertooth?

Regards,
TCIII AVD


(YumaMike) #12

I sure appreciate your quick response, thanks.
I now have another problem in that the Rover backs up to the WayPoint and oscillates left to right very quickly while navigating to the WayPoint.
I have a few more settings to get rite before it will Navigate and work correctly.

Here are my current settings:
Standard Params: conservative settings
Channel 7 = Learn Waypoint
Target cruise speed in auto = 2.5
Base throttle % = 30%
Failsafe Action = hold
GCS = disabled
Throttle Failsafe = Enabled
Be-sure to write the Params before exit

Advanced Params:
APM 2.6 normal mount = none
Compass Orientation and GPS normal mount, arrow fwd
RC trim PWM #3 = reverse – center – forward
Not changing the RCMAP param, changed in transmitter
Be-sure to write the Params before exit

You wrote:
First off how about providing some information concerning your setup:
What model Sabertooth? = 2X32 for RC
What are you dip switch setting? = #1OFF, #2ON, #3OFF, #4OFF, #5ON, #6ON
What is your SKID_STEER_IN parameter set to? = 0
What is your SKID_STEER_OUT parameter set to? = 1
How is your receiver connected to the APM receiver inputs? = REC #1 roll,2 pitch – APM #1, #3 – APM out #1 Left motor, #3 Right motor to Sabertooth input.
Be-sure to write the Params before exit

Let me know what to change to correct my problems.
YumaMike


(Thomas J Coyle III) #13

@YumaMike,
You might try reversing the APM servo outputs to the Sabertooth.
Regards,
TCIII AVD


(YumaMike) #14

Great job analyzing this problem, goes against the Manufacture suggested setup configuration. I switched the RC inputs to the Sabertooth controller Motor Left and Right and it solved my problem with the Rover not navigating properly.
Here is the YouTube URL to view my first Autonomous Rover Run along with all the setup parameters from MP for reference if needed in the future.
youtu.be/E1URxX87C_U
Thanks again.
YumaMike
[youtube]https://youtu.be/E1URxX87C_U[/youtube]


(Thomas J Coyle III) #15

@YumaMike,
Glad to hear that you got it working. Nothing like the sweet smell of success :smiley:
Regards,
TCIII AVD


(linyuanyu ) #16

how to solve the problem ,I can’t understand the video ,we can’t get the messages from thre video


(linyuanyu ) #17

I have a aproblem in that the Rover backs up to the WayPoint and oscillates left to right very quickly while navigating to the WayPoint.


(Thomas J Coyle III) #18

@APMche,
Please provide the following information:
What navigation controller are you using?
What version of ArduRover firmware are you using?
What R/C system are you using and how is it attached to the navigation controller?
Please provide a tlog and/or dataflash log when using your rover.
Please read the ArduRover Wiki.
Regards,
TCIII AVD


(Andre Luiz) #19

Hi,
I’m having the same problem described here, my rover is moving in circles and don’t reach the waypoint.
my configuration is

Sabertooth 2x12: DUUDUD (Down/Up)
SKID_STEER_IN = 1
SKID_STEER_OUT = 1
RCMAP_PITCH,2
RCMAP_ROLL,1
RCMAP_THROTTLE,3
RCMAP_YAW,4

Do you think it can be parameters configuration? Is it possible compare the parameters list with someone whose rover is moving correctly?

Thanks


(Thomas J Coyle III) #20

@Andre,
First of all, I believe that only the SKID_STEER_OUT should be set equal to 1.
Second, try checking the reverse box next to the Roll Bar on the MS Radio Calibration screen.
Third, try reversing the inputs from the Pixhawk to the Sabertooth ESC.
Regards,
TCIII AVD