Servers by jDrones

Rover spins in circles in Auto Mode


(Andre Luiz) #21

@TCIII
Thanks for the help.
I did the changes but it did not succeed.
Reversing the inputs from pixhawk to the ESC, just reversed the problem.
In AUTO mode just one wheel moves, and in STEERING mode the wheels move in different speeds. The output voltage of Sabertooth is 3.8V in one side and 4.6V in the other.
Doo you think there are more parameters I can change to solve this issue?
Try another Sabertooth configuration?

Regards


(Thomas J Coyle III) #22

@Andre,
You do not have the Sabertooth Mixing enabled?
The Sabertooth should be setup as just two parallel, independent ESCs.
Regards,
TCIII AVD


(Andre Luiz) #23

@TCIII
No, the sabertooth is in independent mode.

regards


(Thomas J Coyle III) #24

@Andre,
I assume that you are using the PITCH input channel for Forward/Reverse and the ROLL input channel for steering right and left?
What Pixhawk servo output channels do you have the Sabertooth ESC hooked to?
Regards,
TCIII AVD


(gmorph) #25

Can you please attach one dataflash log file when the issue occurs so we can analyse it?

Thanks, Grant.


(Andre Luiz) #26

@TCIII
I was using THROTTLE for Forward/Reverse and ROLL for steering right/left.
The channels 1 is connected to S1 and channel 3 is connected to S2.

@gmorph
The .bin file is on the link:
https://drive.google.com/file/d/0BwusY7eCSJghazdocUZFcEplWFk/view?usp=sharing

Thanks


(Thomas J Coyle III) #27

@Andre,
When using the THROTTLE RC channel for speed control you will have no reverse.
Have you read this portion of the ArduRover Wiki?
Regards,
TCIII AVD


(gmorph) #28

Your P gain is high - see below - left is the default, right is your value. Is the turning circle of your Rover really 5 meters?
STEER2SRV_P 1.8000 5.0000

NAVL1_PERIOD is very high at 40 - means turning to navigate will be very slow.

COMPASS_USE2 is set to 0 meaning your rover will on be using 1 compass - the first one.

THR_SLEWRATE is low at 10. That means it will only change at 10% per second. Not a problem - just mentioning it.

You have PIVOT_TURN_ANGLE set to 0 which disables it. I suggest that’s your issue. Please read the documentation here
http://ardupilot.org/rover/docs/parameters.html#pivot-turn-angle-pivot-turn-angle
Try a value of 30 and see how you go.

Thanks, Grant.


(Andre Luiz) #29

@gmorph

Thanks for replying!

The rover is not small, so I thought it would be better using a turning circle of 5 meters. For the same reason, I used a high value for NAVL1_PERIOD.

I set the THR_SLEWRATE small because I want it does a soft starting and stopping. Is it correct my reasoning?

The PIVOT_TURN_ANGLE is set to 0 for it turn in steering mode and not pivot turn. Do you agree this is a better option?

Thanks again.


(gmorph) #30

Does the rover drive ok in Manual mode?


(Andre Luiz) #31

@gmorph

In manual mode the rover moves forward and backward normally but with abrupt starting and stopping.

For turning, if you give a command to turn touching very slightly the joystick it turns correctly, but if you push the rudder stronger it pivots despites of PIVOT_TURN_ANGLE is disable.

Regards


(gmorph) #32

Hmmmmm. Could you please do a test drive ONLY in Manual mode with the stopping and starting issue and then attach the dataflash log file from the SD card please?

Thanks, Grant.