Rover ignoring waypoints

I recently set up a rover with the specs:

  • two motors from a hoverboard and two small wheels to keep it in balance.
  • an ublox gps module
  • a speedybee flight controller
  • a radio receiver and control unit

What I tested and works:

  • I can move it manually with the radio control. Goes forward and takes turns.
  • Connecting the ground control app through usb I can see the orientation and position are ok.

What I would like it to do:
Follow a path of 3 waypoints in a parking lot.

What it does:
When started in auto mode it goes forward.
It does not matter in what direction is facing initially, always goes forward.
Lifting it and moving it to the waypoint does not seem to change the behavior (no turn no stop, just forward + an acceleration guessing fromt he PID)
Having the PC connected while having it lifted and moving it around will display the rover on the map and draw the path on the map. ← assuming it knows where it is.

I went through the list of rover parameters and fiddled with them. Also reset the settings a few times. Getting the same result.
I would greatly appreciate any pointer to what parameter might be worth checking or what I might be missing.
I tried two ground control apps: QGroundControl and APM-Planner_2-2.0.30-rc3, there are some differences in the interface, but the result is mainly the same.


This could be the same issue reported over and over. Testing in Manual Mode tells you very little about correct configuration, you need to test in Acro Mode and get the servo directions correct. See Motor Test here: to start:
Motor Test

1 Like

Thanks for the reply and the tip.
In deed it behaved a little different in acro mode: it was turning more aggressively and tended to oscillate when turning. I reduced the P gain from 0.2 to 0.1 and it seems okay now. (let me know if there was another parameter that should have been changed instead).

So now I checked and it works okay in acro and it works okay in manual, but it still does not care about waypoints. It just goes forward and ignores the waypoints. (I can place it in any direction and still goes forward)

I am attaching the log file as well, maybe it helps. For context, I navigated it manually from within a building outside into a parking lot, waited ~1 min or so to get the GPS fix and started auto mode. Armed/disarmed it several times, while changing its angle.
The log file: 14.37 MB file on MEGA


The basic tune is horrendous. You’ll need to spend some more time in this section of the wiki:
First Drive with Rover — Rover documentation (

You have multiple EKF failsafes that I can only assume stem from poor configuration followed by force-arming with ARMING_CHECKS=0.

Additionally, GPS precision is very poor, with high HDOP throughout.

Spend some more time with the basic configuration, and make sure your GPS antenna is placed up and away from any sources of interference or obstruction. This vehicle is not ready for autonomous navigation.