Rover can't go straight

I recently made a rover and start tuning, to my surprise, the rover won’t go straight when turn, i did a simplest 2 point test, and tried all kinds of combination of the parameters mentioned in the rover tuning wiki pages, but only to fail. So i come here hope to get some help.attached is the image that i did the test.


It would probably help people diagnose the problem is you provided more information about your rover.
What controller are you using? What sort of motors are you using? Motor controllers?
What sensors are you using?

I haven’t used ArduRover in a rover myself but I plan to do so soon. I’ve built plenty other other rolling robots and I’ve found encoder feedback is really needed to move in a straight line. It’s probably possible to get a rover to drive straight without encoders but some sort of feedback is usually needed. Do you have a magnetometer? If so, how is it mounted.

Besides the information I mentioned earlier, it would probably be helpful if you posted a photo of your rover.

Adding a file which includes your parameters would also be helpful. If you have a log from the attempt, that would likely be helpful too.

Thanks for your feedback.
The rover is equiped with pixhawk2.4.6, with 2 driving brushless motor that i got from a hoverboard, skid steering mode, working no problem in manual mode.
I use ardusimple base and rover rtk configuration to get cm precision, and external compass for heading.
Noticed that when mission starts, the red rover heading line will change to the green target line, however the black gps track line still towards a bit right, then rover will follow gps line first, and correct by software, thus the rover goes no straight.
I dont know the reason behind, and cant understand even just two points mission no pivot turn the rover still wont go straight.

Can you post a copy of your parameters and bin log file from the mission? That will help in diagnosing the issue.

The parameter file is attached0703 firmware4.0 fmu3 with overshoot acro para adjusted.param (15.7 KB)

I read very carefully about this thread and some other threads:
Seems the overshooting problem long exists, most of them did not tell clearly how they solved the issue, I also tried to add a 1s delay as Randy suggested but did not change much.
Btw the wiki is useful, is there also a handbook or just illustration that we can learn how those parameter work?

I’m not sure if it’s an overshooting issue. Overshooting usually looks like a wavy “s-curve”. I’d really need a bin log file to analyse further.

They can track very straight if configured and tuned properly. Some interesting test info in this thread when I was helping out a guy who wanted to build a running pace vehicle. Impressive performance from my rover on a test track.

If I were to repeat that now with S-curve it would perform even better.