Servers by jDrones

Rover-3.2.0 released!

release
ardurover
stable-release
apmrover2
ardupilot

(rmackay9) #1


After months of development and beta testing, Rover-3.2.0 has been officially released as the default ArduPilot rover software. Full details of the changes in the Release Notes and also copied below:

We have also revamped the Rover wiki including these pages:

Unfortunately because of the very large change to the steering and throttle controllers, 3.1 users will likely need to re-tune their steering and throttle controllers. Hopefully the wiki links above will help get these users get through the tuning quickly.

Special thanks to our beta testers who spent many hours testing Rover-3.2, uncovering issues so that the wider community can more easily enjoy a (hopefully) solid release. Also thanks to eLAB (my main sponsor) for their support.

Despite all the beta testing there may be some unforeseen issues so if you find problems, please report them in the Rover-3.2 discuss forum and we will attempt to resolve them as quickly as possible.

P.S. the video above is an AION robotics M and R1 rovers


Rover-3.2 released!
(Sebastian Schürmann) #2

I just put my pixhawk back into my rover. I am still running rc4. I noticed that throttle slew rate also influences throttle in manual mode. Was it always like this or was this added recently?


(rmackay9) #3

Sebastian,

That is a new change in 3.2.0. I forget exactly which release candidate we introduced that change in but it was perhaps -rc3.

It’s of course possible that we could make it not apply in manual modes but if the intention is to soften the throttle response in autonomous modes the ATC_ACCEL_MAX parameter allows reducing how quickly the desired speed changes.

-Randy


(Russ Jarvis) #4

THANK YOU! So many amazing new features, can’t wait to try!


(John Easton) #5

I have never had a problem with throttle control with any of the Pixhawks I have had previously.

It was simple:
a - Radio Calibration
b - Min 0% and Max 100%
c - Auto Mode Mission Speed = 4m/s
d - WPT arrival = 20% throttle

Now the trim is all over the place, min values are super high and auto is full throttle !!!

How can I take the throttle back to the old way it used to work before 3.2?

Yes I have read this - http://ardupilot.org/rover/docs/rover-tuning-throttle-and-speed.html


(rmackay9) #6

@Fishton,

Older versions of Rover can be downloaded through the MP’s Install Firmware screen using the “Pick Previous Firmware” link on the bottom right. If this isn’t visible, go to Config/Tuning >> Planner and set the “Layout” to “Advanced”.

The other option is to try and get the throttle tuned with 3.2. It’s not super difficult I think but it is different from 3.1. If you’ve got a dataflash log I can probably help figure out what’s going wrong.