Servers by jDrones

Rover-3.2.0-rc4 released for beta testing

ardurover
beta-testing
beta-release

(rmackay9) #1

Rover-3.2.0-rc4 is now available for beta testing. It should appear in the Mission Planner (and perhaps other GCSs as well) within a few hours.

Full release notes are here and also copied below:

  1. Steering controller supports feed-forward (reduces wobble)
  2. WP_SPEED, RTL_SPEED parameters allow speed independent of CRUISE_SPEED
  3. Dataflash logging improvements for steering and throttle
  4. Remove auto-trim at startup
  5. GPS reports healthy even without 3d lock

The big change is the 1st one which resolves a wobble found by Kelly Shrock on the ArduRover-r1 (video). TBH, it was quite a large omission in the steering controller to not support “feed forward” so we suspect this will improve vehicle steering control quite a lot.

I’ve updated the “Tuning Steering Rate” wiki page with new advice that the ATC_STR_RAT_FF is the most important parameter to tune to get good steering control (previously it stated ATC_STR_RAT_P was the most important).

Also I’m hoping/expecting the mission planner’s “Basic Tuning” page will be updated soon (issue here) to allow updating the parameter but until then you can just set the parameter directly using the “Full Parameter List” or “Full Parameter Tree” pages.

Thanks again in advance for any testing you can do. I really expect that this is our last release candidate before going live.


(rmackay9) #2

(RoboBill) #3

@rmackay9,

I just tried it and am still getting Failed to change mode error. I’ll work on the logs tomorrow per your thoughts on the c3 discussion.

Thanks

RoboBill


(kellyschrock) #4

What mode are you trying to switch to? If it’s Smart RTL, I was having trouble with that because I had it set to auto-arm on boot, which meant that I didn’t have a good home position. I changed to manually arm via CH7 so I could arm at a point where I had a good fix, then was able to switch to Smart RTL.


(RoboBill) #5

I’ve been trying to manually change from Manual to Auto mode with the Ch7 switch . I figure the problem is me screwing around with all those other tempting MP parameters plus I’m using a POZYX for guidance.

RoboBill


(kellyschrock) #6

On a related topic (hopefully): Has anyone managed to calibrate the compass on rc4 at all? I’ve tried probably 10 times and it fails every time with any level of fitness, no matter where I am. I finally resorted to setting the compass offsets manually to 0, which gets yaw to report accurately relative to actual yaw. Driving around and testing that, I get a “ground mag anomaly, yaw realigned” message, and yaw changes to a wrong value.


(Esa Attia) #7

Hi @rmackay9,

I’ll start looking into testing this sometime next week when I get back from Christmas break.

Awesome work so far guys !

Just some questions.

  1. How do we know when to stop fiddling the feed-forward (ATC_STR_RAT_FF) value before moving onto the other PID values? What initial value should we start with?

  2. Is this issue still a problem in RC4? - Rover-3.2.0-rc3 released for beta testing

  3. IS the “follow me” functionality enabled in Ardurover? If so is it difficult to integrate before the release version?


(Esa Attia) #8

Is there any support for full PWM signals for brushless motors?

I am currently using a brushless roboteq motor controller (with RC pwm signal as input).
Would be awesome if ardurover is able to output full pwm signals.

I suspect you might get better control resolution by being able to use full pwm signals rather than the 1-2ms range that RC PWM signals operate in.


(rmackay9) #9

Esa,
We do support outputtting the raw pwm values by setting the motor-type. Ive never testes it myself though.

Follow-me is implemented in the ground stations which send commands to the vehicle while its in Guided mode. So for now its bestfor the GCS guys to comment…

For tuning… best to just try and see for yourself. 0.2 is the default and a good place to start.

I see there are a couple of reports of various issues on the -rc3 release thread but im not really sure which remain. Maybe it would be best if people comment below on any problems they are still seeing so i dont lose track of anything.


(Esa Attia) #10

Was there a reason why the latest build failed

http://autotest.ardupilot.org/

drive.APMrover2 - FAILED (98.7 seconds)


(RoboBill) #11

I too did have some trouble “updating” to this beta. I eventually went back to the latest stable version then successfully installed c4.

RoboBill


(Esa Attia) #12

Also how do you get in ACRO mode … there seems to be no option to select it

Currently running RC4

[1515392265.562634979]: FCU: APM:Rover V3.2.0-dev (5a5be917)


(Esa Attia) #13

Also when Tuning the rover should the NAVL1 parameters be all set to zero?

I am currently doing some preliminary tuning indoors due to a storm here in Sydney.
Getting nonsense data as I believe the speed is derived from GPS and IMU.
When I do a spot/pivot turn in steering mode

I get this

pidacheived hardly moves.

Just trying to go through the wiki to see if any questions pop up before I go outside to test.


(Esa Attia) #14

Also I noticed that I keep getting a warning in the terminal window saying … This has been the case since I starting using ardurover …not just RC4.

[ WARN] [1515396895.563497298]: GP: No GPS fix
[ WARN] [1515396926.562950342]: GP: No GPS fix
[ WARN] [1515396956.563487449]: GP: No GPS fix

while on mission planner it says RTK fixed (currently indoors sitting under a gps repeater)


(rmackay9) #15

Esa,

If you’ve installed the latest beta (3.2.0-rc4) then the name of the firmware should be APM:Rover V3.2.0-rc4 (d7ceba8c).

To make ACRO mode available you’ll need to use a Beta version of the mission planner (or perhaps some other GCS) or directly set one of the MODE1~MODE6 parameters to 1.

There shouldn’t be any need to set the NAVL1 parameters to be zero. They won’t be used in Acro or Steering mode. They’re only used in Auto, Guided, RTL and SmartRTL.

We occasionally get Travis failures when the travis servers (nothing to do with ardupilot) hit temporary issues. I’ve kicked off the failing job and it’ll probably pass this time.

Re the GPS message, I’m not sure what that is or where it’s coming from. It’s not a string that ArduPilot outputs. These are the startup messages I see in the Mission Planner’s Flight Data, Messages tab.

Set HOME to 36.32434 138.6393 at 948.03m
EKF2 IMU1 is using GPS
EKF2 IMU0 is using GPS
EKF2 IMU1 Origin set to GPS
EKF2 IMU0 Origin set to GPS
u-blox 1 HW: 00070000 SW: 1.00 (59843)
EKF2 IMU0 tilt alignment complete
EKF2 IMU1 tilt alignment complete
Failsafe trigger 0x1
PX4v2 00410038 30365104 30353333
PX4: fc469199 NuttX: 1bcae90b
APM:Rover V3.2.0-rc4 (d7ceba8c)
EKF2 IMU1 initial yaw alignment complete
EKF2 IMU0 initial yaw alignment complete
GPS 1: detected as u-blox at 115200 baud


(Esa Attia) #16

hmm I’m using the binaries found here

http://firmware.ardupilot.org/Rover/latest/navio2/

is this not the place for it?

As for the GPS warning …maybe that is a navio2 thing … I will chase this up in the emlid forum.
Not a major issue just annoying seeing the warning every few seconds


(rmackay9) #17

Esa,
It would be better to use the “beta” which is here: http://firmware.ardupilot.org/Rover/beta/navio2/
Have you posted a log anywhere? Maybe I can have a quick look and see if there is anything obviously wrong anywhere.


(Esa Attia) #18

Hi @rmackay9

Today I tested out RC4 beta. I used the beta link that you suggested.
It was very stable.

As for tuning adventures. I still have issues. Rather than clog up this thread.
I’ve posted my problems here

https://discuss.ardupilot.org/t/need-help-with-tuning-rover/23192/4

The log file in that post.

Thank you

Esa


(Esa Attia) #19

I also noticed that this parameter is not mentioned in the wiki

ATC_STR_ANG_P: Steering control angle P gain

Is this value only used when tuning NAV or is it also used for tuning the steering rate?


(rmackay9) #20

Esa,

I haven’t documented the ATC_STR_ANG_P parameter yet because it’s only very rarely used. It’s only used in Guided mode when a SET_YAW_SPEED or SET_ATTITUDE_TARGET command is received from the ground station or companion computer.

In future versions we may use it as part of the pivot turns for skid-steer rovers… but not yet.