Servers by jDrones

Roll/Pitch doesn't reach DesRoll/Pitch - PID tuning


(P) #1

Hello guys. I am a newbie in the copter world. I used to use APM in planes and I hope that you can help me do it right in copters. I’m trying to tune my copter. I’ve tried a dozen different PID settings (and copter fly not bad but always is a little bit twitchy (even in stabilize without input)). Also, I can’t deal with these problems.

  1. ATT.Roll/Pitch does not reach ATT.DesRoll/Pitch after large, rapid changes of Des.xxx.
  2. Another thing is that I can not suppress those small vibrations that appear all the time and I’m afraid that they may be harmful to the motors.
    When I approach the solution to the first problem, the second one is getting worse and vice versa.

Before attempting manual tuning, I tried to use the Autotune function, but I was not happy with the results.

If someone can help me I really appreciate that.


Log: https://www.dropbox.com/s/04bh20u3beq70gn/00000062%2015%2019%20007.BIN?dl=0


(Dave) #2

Describe the build components of your multirotor. It will help with tuning advise.


(P) #3

Ok,
frame: Foxtech Hover 1 (quadrocopter 640mm)
motors: T-Motor MN3508 KV380
ESC: Foxtech Multi-Pal 40A OPTO
Battery: 6S 9Ah
Payload: 0,5kg
The Cube Black
I think that’s all.


(Mike Boland) #4

Have just completed a couple of builds of the Hover1.

Our autotune produced some very nice responses and it flies very well.
But
It was necessary to adjust the roll/pitch rate filters down from 20Hz to 10Hz
Lower the aggressiveness to 0.05 (min)
I am assuming you are using 15" props.

It is jumpy in the DES to Actual roll/pitch and our assumptions are the frame has a lot to do with it.