RM3100 & Pixhawk 2.4.8


As the title I have a Drotek RM3100 and Pixhawk 2.4.8. I wish to use this in my boat. Connecting the RM3100 to i2C does not show up in the HWID or the list of compasses.
Using the latest stable FW. RM3100 is activated in the parameters also.
Any reason why the mag is not working please?

What firmware do you have installed? The wrong one, fmuv2?

fmuv3 0043002E 3339510F 34383938
ChibiOS: 38022f4f
ArduRover V4.2.3 (2172cfb3)

Update to ArduRover 4.4.0-beta1

And this will solve the issue?

It should, that compass is supported on newer firmwares. If it would not solve the problem I wouldn’t advise it.

Thanks I’ll give a try :+1:

fmuv3 0043002E 3339510F 34383938
ChibiOS: 1ec9f168
ArduRover V4.4.0-beta6 (fb8864e2)

Made absolutely no difference. Also double checked the cabling and swapped SCL & SDA around.
Any other suggestions please?

Ok so for the benefit of the doubt, I installed Arduplane .4.1-beta1
fmuv3 0043002E 3339510F 34383938
ChibiOS: 1ec9f168
ArduPlane V4.4.1-beta1 (6e3279bd)

Also tried Copter
fmuv3 0043002E 3339510F 34383938
ChibiOS: 1ec9f168
ArduCopter V4.4.1-beta1 (720e8c26)

No sucess and nothing showing in HWID or compass.

Any help here would be much appreciated

The only 2 things left to try is Pixhawk1 Stable and/or 4.5-dev. I don’t think the Dev version will make a difference. On the Custom build server it says that compass is included by default for Pixhawk1, there is no build for fmuv3. FWIW when I had those 2.4.8’s flying I used Pixhawk1 but there are different versions of those around now. I shit canned all of them.

Thanks for your input and guidance.
Neither of the two last suggestions worked either.

I’ve come to the conclusion that either I have a faulty Mag module or that the lowly 2.4.8 isn’t compatible.

As this kit is for a fishing bait boat, it’ll be much easier to move the existing FC away from the interference. The boat employs RTK and I have a spare F9P so maybe look at GPS for Yaw.

Which vendor did you purchase the sensor from? The three axis inductors on RM3100 have very strict soldering requirements(Refer to the data sheet for RM3100), and might some sensors have faulty axis inductors. You can try checking their resistance value, which should be around 36ohm for each good one.

Also note that there are several vendor RM3100 SPI/I2C module sensors whose physical axis orientation is incorrect as I know. @Reaperman

If you are use a DIY sensor, you should check the vendor’s manual. The pins of these modules need to be soldered with SPI/I2C enable. If it is works I2C mode, you need to use two pad to select its I2C address.

Suggest the Matek AP_peripheral CAN RM3100

1 Like

Ha.Ha. May I advertise here? Qiotek has a CAN module for RM3100, if you would like to use the CAN bus.

I have read the manufacturer’s manual and it has two interfaces, SPI/I2C. It should be selected to work in SPI or I2C mode through pads. Could like to you open the shell for inspection?

I could open to inspect but I am unsure what I am looking at to be honest or what tests I can carry out. I have been trying to connect via i2c

It must choose to work in either SPI or IIC mode, but unfortunately, the vendor website does not have more guidance on these. Can you contact them for support?

From the RM3100 chip manual.