Servers by jDrones

RFD868+ "getting params 1" never finishes? (Solved)

I’ve got a pair of RFD868+ that I’m forever having problems with. On connection it says

GettingParams
…endlessly!

The HUD moves, all the data fields update correctly and quickly, just the parameter retrieval never completes.
I have tried all settings on default and different settings like enable/disable RTS/CTS, ECC, OP RESEND, etc but nothing. Once or twice it showed “getting params” for about 10 minutes but only got around 12 of them. The red LED flashes constantly but still never completes getting the params. COM port obviously is correct as is the baud of 57600 on both otherwise the HUD and data wouldn’t update.

Have been Goggling for a couple hours and none of the solutions work, I have even flashed new firmware to both and then set all settings on default, but nada.

Could it be faulty RFD’s, otherwise I’m out of ideas?

Many Mission Planner issues can be fixed with updating to latest MP Beta. Not sure about this particular issue but worth a try. From the Help screen bottom right button.

Enable console in Mission Planner (Help screen - show console) and look what happening, it is quite verbal…

this is normally a sign of one way comms.
check your cabling to the radio

Totally agree with Michael. This is probably due to a corrupt connection of the RX signal on the uav side, or the tx signal on the ground side.

The phenomena happens as mission planner sends the command for getting the parameters, but the pixhawk never gets that message. It also means your connection from pixhawk to ground is working, as you can see other data and the hud moving.

Thanks Michael and Anthony. Knowing now where to look I checked the cables on the airside radio and found a wire broken near a plug, works as expected now.

Thanks again.

A last question please: now the download of the parameters is very slow, taking about 3 minutes to get them all, is there a way to speed this up or reason for the slowness?

there are a few things you can try
do you enable rts/cts on the radio
also try change sr1_params to say 100, this depends alot on the link though
other than that, depends on where the bottle neck is

Normally with the RFD radios, it should be fairly quickly. What’s your baud rate?

Are they very close together? If your test setup has the 2 units very close together, there might be a chance the ground control unit gets a too strong signal. Try to put them at least a few meters apart (like social distancing, haha)

I think it is a signal related issue. But not sure. Hard to tell without being there. Did you connect the antennas?

Servers by jDrones