"Getting Params" Stuck - Again

I have read every troubleshooting step possible on this topic and still can’t figure it out. Attached screenshot shows that up/down is OK (not a wiring issue, I believe). The indications are typical of problems I’ve seen others report where the telemetry data seems to be coming in fine but the ability to read/write configuration is not possible because stuck at “getting params”.

Arduplane 4.09 on Matek H743 Mini
Holybro V3 (tried SiK 1.9 and 2.0 on HM-TRP) connected to RX6/TX6
Mission Planner build 1.3.7852.5635 with BETA updates applied

Software Configs Tried

  • Low Latency
  • ECC On/Off
  • Lower Power and Separate radios by 10+ feet (although link quality seemed good already)
  • Mavlink1 and Mavlink2
  • Lower Baud of 9600

Any ideas, should I further downgrade the SiK firmware? If so, I am having difficulty finding it. I am most likely thinking this could be an issue with either using this particular UART or a configuration setting that I can’t think of.

Thanks in advance!

1 Like

following with interest

are you using it in side ?

Yes, indoors. Not sure what difference that makes? Link quality showing 100%.

Multipath is what you get inside 2 signals hit the receiving antenna at the same time
but link will always say 100% this why you get video break up in doors it its Multipathing so it drops the packet so the packet never gets to mission planer

if you have to work indoors do as i do turn down the power to 5 mw or lower move them apart some
or some times i just screw on some 50 ohm dummy loads

1 Like

Hi Colin thank you for this what parameter do i turn down please,many thank’s,Marty.

i just turn down the radio power to 5Mw and in mission planer set it 57600 baud rate mavlink 1
and Matek H743 Mini prams on that serial to 57600 as well

1 Like

Thank you very much for that,Marty.

@yak-54 Colin, thank you for that suggestion. I had already tried 5mW at a distance inside with no luck. I was really hoping you were right. But just had a chance to take both radios outside and no luck at a distance with 1mW and multiple orientations in clear space. Just stuck at “Getting Params” and the link quality still showing OK.

Any other configuration settings to try would be greatly appreciated.

BTW @yak-54 multipath is an interesting issue I am familiar with in my professional life. We have used the timing differences of interference at multiple locations to determine location of the offending reflector.

may be we have to start looking at the link for the radio to the PC

About the link between radio<–>PC that would be the USB port. I have matched the connection rate to the radio at 57,600 but not sure that matters. That had been suggested to someone else but it seems to be unimportant which makes sense. Regardless, I have that set at the same connection rate as between the 2 radios. I think it’s important to note that the telemetry data is flowing just fine and the ‘Status’ window indicates the data flowing in both directions. That is why I think it’s a software setting somewhere that I am just not experienced enough to fiddle with.

Thanks so much for answering and trying to help me work through this.

Not an easy one to get to the bottom of but I had a similar problem: RFD868+ "getting params 1" never finishes? (Solved)

here a screen shot of old 433 uhf radios
may be try turing on RTS CTS ?

this is the Pc coms port

Can you upload your prams file as well

I had actually read the link you sent already @Graham_Dyer as I was troubleshooting. Thank you! I just don’t think it’s the RX/TX pins as I tested continuity and the stats page shows RX and TX data. Unless there’s something about the stats page I don’t understand.

@yak-54 I am out of town for the next week, maybe two so will attach the params file soonest. So far I have tried modifying almost every setting on the SiK configuration (matched on each radio of course). I think maybe the next thing I need to try is a different UART on the FC.

Thanks so much

Do you have lua scripts enabled (SCR_ENABLE=1)? I had similar issues when the scripts were enabled - not sure if it makes a difference…

Thanks for the suggestions gentlemen. I checked continuity one more time and no issues. I have admitted defeat and resigned that I won’t be able to make this work. Gonna take a break and retry this in a few weeks.