Reverse channel input - set in parameter list has no effect (do not reverse)

As in my Topic described: I reversed in the parameter list the channel input of (e.g. channel 2+3 to reverse)

After restart of the controller (Pixhawk 2.1 Cube), it has no effect. The channel is not reversed!

Any idea what I am doing wrong?

What FW version are you using? What RC protocol, how is it connected?

I am using Mission Planner 1.3.66 with the following FW:


It is connected as following: Joystick (PWM) is going into a PWM to PPM Signal Converter. From the Signal converter the PPM Signal is going into the Pixhawk 2,1. All is working fine in Radio Setup (also the two channels which I like to reverse). Also the calibration was successful. Min and Max is fine, just the reverse is not working.

I hope I got your questions and answered all of them

What ever I am trying: Still the same! I am running now firmware 3.6.9 but same problem

Why not just reverse the channel at the transmitter?

Because my RC do not have this function (It is a self made one)

how are you testing?, the green bar things on MP radio input page seem to sometimes ignore the reverse parameters

I am testing with the green bars in MP. I will check it tonight. Thanks

Seems like you are right. Because I have another issue posted regarding the arming process. Instead of arming it starts compass calibration. But of course it is doing it because I move the throttle in the wrong direction (because I thought it is not reversed. I will confirm in the evening, but I am 99,9% sure the problem is solved. Thank you so much

np, first think would be to update mission planer, next try with QGC

Thanks Peter! You are right. Solved with your advice!!! Thank you so much!!!

1 Like