(request help) Drone landing or failsafing with little to no error or warnings? (SOLVED)

Hey again all,
I am chasing my tail with this one…

My quadcopter is landing (like a failsafe) with little to no warnings or errors in some of the logs that I can see…I did just discover a couple logs that had GPS glitches, as well as EKF primary errors… I have been trying to determine if any of my sensors are causing interference with the GPS or the cube by removing them all and then plugging them in one at a time, but the landings are sporadic…sometimes it flies perfectly fine, sometimes it flies well and then acts like it loses GPS and altitude hold capability and drifts around, and then lands…

Upon reviewing this log, it looks to me like the drone is randomly shifting out of loiter to stability mode and back to loiter, back and forth… but I don’t know why. and again, when I review the logs I see no errors found in the log review window… In the auto analysis, I can see that the GPS had an “unknown”. On another log, the GPS was fine but the IMU said it had a mismatch.
I am lost and need somebody with more expertise to diagnose this if possible

Any insight into this is appreciated

Check out the MSG information in the log for some clues. I see some strange things, but don’t know what you did… so I can’t tell what happened. The messages suggest that a GPS glitch occurs at the peak of your flight.

I see a short flight (15sec?) which rises to 16m and then immediately returns to near the ground. The log you posted did not change mode during flight, according to the MODE information in the log.

Just FYI, you’re posting this in the “Hardware” sub-forum, which may be monitored by folks unfamiliar with Copter-specific software configuration and troubleshooting. If you don’t find the help you want here, you may want to move your question to that sub-forum.

1 Like

Thanks Huntor, did not realize it was in the hardware forums.

I can post another log, I just grabbed one and it might have been the wrong one from the cube, one of the logs I have shows that it was switching out of loiter to stabilize mode and back and forth.

The log you looked at in regards to my flight: I just took off and let it hover, it tried to drop to the ground and then it rose back up, like it was slow to respond to my throttle commands. I have seen this issue before with a GPS glitch, the problem is that we cannot figure out what is triggering the glitch… we have unplugged all external / non cube related peripheral devices and it still persists.

Huntor I am going to drop you another log, if you can look at it I would be appreciative.

This one shows a GPS glitch and an EKF primary error.

Any hints as to what causes those at the same time?

Did you take a look at the GPS messages? It look like they begin at TimeUS=63807712, stop at TimeUS=116396055, and then don’t begin again until TimeUS=207210908. This means there’s a ~90sec pause in you GPS information.

It looks like your aircraft was sitting on the ground during this time, so perhaps you know what caused this? But I see the GPS Glitch (as reported in MSG) occurring approximately in the middle of this GPS pause.

Yes I believe it was after the drone landed, I made a change and put it in the air again to see if my changes affected the flight in any way. but unfortunately it did not, the quad still acted like it didn’t have a GPS or altitude hold and fell to the ground in a controlled descent.

Let me make sure I understand correctly:
In the flight log 2018-12-12 15-42-07.bin, you performed one successful flight with no GPS glitch. You then changed something, and did another flight, where the GPS glitch occurred. Is that correct?

If yes, then I don’t understand what you’re asking us to look at? Do you want us to look at the first flight, or the second one?

No, neither flight was successful… All of my flights yesterday resulted in the quadcopter acting erratically and landing by itself… almost like a failsafe trigger, but my logs showed no failsafe landing. That’s the strange thing is that in some of my logs, it does not show any errors, and then in other flight logs, it shows a GPS glitch and an EKF primary error. It’s hit and miss on whether or not there will be a visible error to see in the logs… but the aircraft performs the exact same (poorly) every flight no matter what I do.

I see a heavy unbalance here. It seems that motor1 and motor2 maxing out to keep copter in balance, while motor3 and 4 spins much slower. Because of this, there is not enough lift for the copter to stay in air.

The only thing that came into my mind are the propellers, did you checked that all motors have the correct props?


Andras, are motor 1 and 2 the motors on the right side of the aircraft, if I am looking at it from top down?
I have the correct props on, they are all 10x4.7 Quanum carbon fiber props and they are all on correctly. What could be causing this I wonder? They are brand new motors and the props are balanced

motor 1 and 2 are the ones opposite. 1 is right front, 2 is left rear.

1 Like

Ok that’s good to know… do you have any suspicions or any tips for me to rectify this? I don’t know what would cause this to suddenly happen when the quadcopter has been flying perfectly for a couple of weeks now. I’m not sure why suddenly they would start spinning at different speeds

I have ran through an ESC cal to ensure that they are calibrated, the process I use is turning on the spektrum and pushing it to full throttle and then powering on the drone, unpowering and powering on again and waiting for the musical tones, and then dropping the throttle again and listening to those tones until they are finished.

how your compasses located ?
I see heavy influence in the mag by the motor output. Which can cause constant yaw. And if your copter is heavy and underpowered that can cause the same.

1 Like

We are using the compass inside of the Here2 GPS, and the GPS is up on a hobby GPS mast above the aircraft, the internal compasses in the cube are disabled. the mast is about 5 inches up in the air away from the body. I have seen some Yaw characteristic when flying, it hasn’t affected the aircraft too badly but occasionally I do see it try to yaw a little bit one way or another.

The copter weighs around 3lbs 12.3 oz with all up weight, and the motors are Tiger Motor Navigator series 780kv (2212-21) motors.

@Eosbandi Would the heavy unbalancing mean that the motors aren’t working together in the correct way, or do you think my copter is unbalanced? I have a pre built frame that is pretty solid, and all of my weight on the aircraft is as balanced and close to the CG as possible. It doesn’t feel heavy in the front or rear, or left or right sides. I’m confused as to why the motors are acting this way out of the blue, if this is indeed the truth.
I can’t imagine that it’s over weighted at less than 3.1lbs

I had a similar situation with motors 1 and 2 working harder then the other two and it turned out that they were not level any more. I had to change the motor holders from plastic to metal ones as it hapened more than once. Worth checking it out.

1 Like

This is fixed, Not sure what caused it but I am leaning toward a damaged or malfunctioning pixhawk cube, I replaced it and raised the GPS up higher from the airframe and recalibrated the ESC and then re tuned the new cube to the old cube’s PID’s and its flying smoothly again. I brought the GPS back down to its original height and it flies fine still. So my guess is in a rough landing or a crash, the old cube got damaged somehow.