Servers by jDrones

Receiver and PPM Encoder connections

Hi, I’m building my first quad with these specifics:

Specifics:

  • Pixhawk 2.4.8 Flight Controller
  • Emax XA2212 1400KV Brushless DC Motor
  • 40A ESC 2-4S Simonk Brushless ESC
  • 4S1P 1300mAh 75C 14.8V LiPo
  • Flysky Transmitter FS-T4B
  • Flysky Receiver FS-R6B
  • 12V to 5V converter to feed receiver

Mission Planner version:
image

And my problem is with ESC Calibration but more specifically[probably] with radio values. The values I get are these with trim sliders in the middle:

and ESC Calibration Results in this, [looks like ESC don’t arm?]:

I think my Radio connections are the problem which looks like this:
image

But with some research, I found little to no information about Receiver/Encoder/Transmitter connections [with the ones I have]. And since this is my first drone, I have no idea if they are right or wrong===>

Informtaion about Encoder connections I found:

Information about Receiver connections I found:

But there is a lot of missing information [at least for my level of understanding].
Like why doesn’t my encoder and receiver say
Throttle channel
Yaw channel
etc.
but say
CH1
CH2
or
IN1
IN2

Can someone help me figure out what (if anything) is wrong with my radio values, or if there is anything wrong with my connections, or am I doing something wrong with my calibration process?

P.S: I had another flight controller which I swapped out according to suggestions I got from here:


but since I’m no longer using Copter 3.2 and upgraded to Copter 4 I am moving my questions here.
Plus it looks like I won’t get more help on that topic.

Well, reading a little bit your setup, i saw that you are using esc with simonk firmware… as i know they are not fully compatible with ardupilot… bheli firmware perform better.
I suggest you change the ppm encoder and look for sbus protocol… ppm its analog while sbus is digital… sbus is more fast and more precise.

I would agree BLHeli firmware will perform better but there is no compatibility issue with SimonK firmware. Many are still using ESC’s that run SimonK firmware with Ardupilot. PWM is PWM.

A week doesn’t go by I don’t think where someone isn’t posting about buying one of these cheap kits. Sure, poor quality and far from modern tech but compatibility isn’t an issue.

I had Skywalker 30A HobbyKing ESC before, not sure what “sbus protocol analog/digital” means though, but my hobby shop suggested I get Simonk, so I have 2 types now.
Tried it with both, same result. Though I have no idea if their firmware is any different.

Just so anyone knows I replaced every part in this kit at least twice before.
[Bcz everyone’s first suggestion is “Buy a new one”]
Except for transmitter and receiver. So my last resort will be buying another RC/TX but before that, I want to try everything else.

I will make this work one way or another since I already wasted this much afford. Even if I have to buy a pre-made one and dissect it. But I am curious, how does a normal person start learning about drones. I feel like I am making every mistake possible to learn this. Here I thought I made my research watching other ppl build a drone from youtube videos and other drone building sites.

well, developers are here for every suggestion you need.
specially when you are building a drone it’s important make a little bit of research about the components… settings… etc.
Everyone of us can make a mistake… its super normal.

So I have a F450 using SimonK ESC’s and they work fine, also using a PPM Encoder to a FlySky FS-R9B and it worked fine and the calibration worked, so it’s not that stuff isn’t compatible. You didn’t calibrate any switches though and your radio looks to only be 4 channels? I’ve only used this setup with a Flysky FS-TH9X 8 channel and that worked fine.

Taking a step back what props do you plan to use with those motors (which are best suited to Planes)? What does that chunk of a frame weigh including the battery?

This is the dimensions(in millimeter) of the frame I designed/printed from my 3D printer:
(EDIT2: fixed a value)


3D design of it:
image

propellers are:
7.5x4.5 inches

I used these equations to calculate propeller and motors (rpm):

Everything adds up to almost 1kg of weight. 834grams without Pixhawks and the cables.
The frame is 327grams.

According to those, this should be able to lift 5.4kg’s off the ground
and if its moving 1m/s it should be able to handle 2.4kg’s

I had no idea planes and quads were using a different type of motor, and don’t know what their differences are. My “super trusty” hoppy shop told me these were ok… didn’t really question them since their kV values seemed ok.

EDIT: Photo of the propellers and other stuff (my first planned setup with arduinos):
image

I think your Hobby shop unloaded a bunch of old stock on you and they are way out of the loop with current tech. So this will fly, for about 5 minutes, but Inrunner motors with collet prop adapters are not the best suited for Multirotors. These are usually found in the cheapest multirotor kits having re-purposed what are typically motors for Planes.

A lot has happened, i have a new hobby shop now but result is not much different.
I also have a new transmitter/receiver
Flysky FS-IA6B
Flysky FS-I6X

I checked every piece one by one and im sure every piece is working as it should be, however im still unable to calibrate my ESC’s.

Radio values are much cleaner now, with the new radio:

However the ESC attempt ends the same way:

Am i cursed ? I’m working on this for way too long now, i have no idea what is wrong with anything.
I will try my luck with the hobby shop again, maybe they will consider helping me out but non of the hobby shops accepted checking my setup so I’m endlessly wondering in internet at this point.

Post your parameter file here, let’s take a look at the configuration.

i think this is the one you mean by “parameter file”


yes.param (17.1 KB)

That’s the one. It’s too bad you have spent so much time on a fundamental problem. You do not have a Frame Class (FRAME_CLASS) defined hence no outputs are assigned. Check out the Servo Output Screen… Here is the Wiki, I would suggest a thorough read thru.
https://ardupilot.org/copter/docs/configuring-hardware.html

after multiple reinstalling the firmware i missed this at last time true, i fixed it now but no change still same problem (replaced the simonk ESC’s weith skywalker ones now)


test.param (17.1 KB)

Edit: My hobby shop also checked my setup “online with photos/videos” and they also have no idea why its not working.

Why don’t you disable the safety switch. I don’t see you pressing it in that video anyway. Perhaps you have but disable it anyway. I never use them.
Set BRD_SAFETYENABLE to 0 and restart the FC.

Ok, i change it to 0


now i get a lot of different sounds but still nothing:

Do they run when using Mission Planners Motor Test function?

Interestingly after doing this “all motors test”

i had only one of the motors working and that was the only one I accidentally connected “crossways” like this, [the rightmost motor has a cross connection]


So is cross-connection is the way to go ? What is the difference between swapping the wirings?
3 of my motors are dead ? [can test it later but i highly doubt it] – will test it
Are there connection problems with the cable (unlikely as well)? – will test it
Wouldn’t 1 of the motors working be enough to get them started with controller ? So even if the motors/cables are problematic, it should be getting started with the controller right ?

You can connect them anyway you want. Reversing any 2 wires will reverse the motor direction. Brushless Motors 101 :slight_smile: Test them one at a time (A-D)

Those are some pretty awful looking solder joints. Perhaps on a motor that’s not running re-solder all leads by 1st tinning the leads completely before joining them with solder. If there are balls of solder it’s no good.

Maybe while fiddling with the throttle during your ESC cal attempts you entered configuration mode and changed something. I would not have bought those ESC’s. A set of BLHeli_32’s is what you want. Configurable in an app plus several other advantages.

Hi ken,

Did you remove the plus wire from the ESC’s to the pixhawk?

Best regards,

Maarten

Servers by jDrones