Servers by jDrones

RE: Using the BBBlue and ArduCopter on Linux


(Seth) #1

Hello,

I am following a gist at https://gist.github.com/jadonk/6080ca92d6e225eb89d33ad7744e1775. Line 13 of this gist states to mv a file (rc.local). I do not have this file for some reason and therefore, I cannot move forward on the commands of this gist.

Seth

P.S. I know this sounds simple and I could just make this file but I figured it would be a normal file within the Debian Linux Distro: 4.4.113-ti-rt-r148.


(Seth) #2

Hello Again,

Seth here. I had to retype line 13 from that gist once I typed line 23. Line 34 needs the sudo cmd before the rest of the cmd.

Seth

P.S. I will report back if something goes awkward again.


(Seth) #3

Hello Once More,

Seth here. Are BBBlue machines working w/ Mission Planner. The BBBlue is a Linux computer (usually). I tried to set up Mission Planner. I achieved this goal. Now, I cannot set up the Linux Board, i.e. BBBlue. I saw online that there was support for this board but I cannot set up the BBBlue.

There are sign-in credentials for my Linux computer. I was going to use ArduPilot by listening to some ideas from other people.

I ran across the support for BBBlue and was wondering, esp. when providing starting signage for the board(s), if APM was needed for Linux support on the starting phase.

I typed no and I typed yes but on my port, com 9, it would not recognize my board as a BBB or BBBlue.

Seth

P.S. If you are using this board and want to assist or provide support, please chat w/ me on this forum.


(MagicRuB) #4

@mirkix should know about the BeagleBone line. And yes, it should connect just fine on Mission Planner. Doesn’t matter if it’s linux or not, it’s just MAVLink data over an IP/serial port.


(Seth) #5

@MagicRuB and @mirkix,

Seth here. Hello…I see what you typed out MagicRuB. My Mission Planner software does not connect. Obviously, esp. since I am new, I am missing something that should have been read beforehand.

Is there a tutorial outside of the main page, http://ardupilot.org/copter/docs/common-loading-firmware-onto-pixhawk.html, that I can follow? Oh and do I definitely need the PixHawk to set up w/ the BBBlue?

Seth

P.S. If I need to purchase this hardware, please just reply w/ some type of info. Thank you already for providing support.


(MagicRuB) #6

BBBBlue is a self-contained flight controller that happens to be a linux computer. You do not need an extra flight controller


(SL) #7

You do not need to purchase anything else.

Assuming you have successfully logged into the Beaglebone Blue and installed Arducopter, make sure you know the IP address of your computer from the Beaglebone, as well as the address the other way around. Use ping to check it.

Then you need to run Arducopter on the Beaglebone with a parameter of -C udp:x.x.x.x:14550 where x is the IP address of your ground station from the beaglebone. Then run mission planner and set it to UDP mode and it should find ArduCopter.

On mine it is a simple case of sudo ./arducopter -C udp:192.168.7.1:14550

It is easy to accidentally get the ports wrong and send the MAVlink messages to the wrong IP. If you see a wall of random text in the beaglebone console then ardupilot hasn’t accepted the parameter and is dumping MAVlink messages here instead.


(Seth) #8

Thank You Fellows,

Seth here, again. Hello once more. I will test out the BBBlue w/out purchasing the extra hardware for now. @SuzL, thank you for replying so quickly. I am still new and trying to find a foothold currently w/ this Linux board.

I will listen to your commands.

Seth

P.S. I will find out how to search for ports. My com Port was 9 and now it does not accept the com port 9. See here:

CaptureOfErrorForFirmware


(Seth) #9

Hello @SuzL,

This is Seth. Um, should I install Arducopter on my BBBlue or on my Linux Desktop or both?

Seth

P.S. If you would, when you have time, please send over a hyperlink of a viable tutorial. I have tried the qmake version for Ubuntu but I have not gotten very far w/ progress.


(ppoirier) #10

@silver2row I suggest you read this
BeagleBone Blue released, Linux-enabled autopilot for 80$

There is a lot of information on the BBBMINI as well:
https://github.com/mirkix/BBBMINI


(Seth) #11

@ppoirier,

Hello sir…thank you for the link. I will look into it.

Seth


(Seth) #12

Hello Everyone,

I am compiling now. The ArduPilot software is on the BBBlue and I am making headway. Thank you for your support. @ppoirier, the mirkix/BBBMINI site from GitHub.com has worked out. I am pretty sure of it.

Seth


(ppoirier) #13

Just make sure you set the correct board type
./waf configure --board=blue


(Seth) #14

Yes Sir,

You got it and so do I. This is great. I cannot wait to get the necessary parts to complete this project. ./waf configure --board-blue

Got it.

Seth


(Seth) #15

@ppoirier,

Hello again sir…I tried that command. I was unsuccessful w/ that command. I was going to use a “config-pin” utility to promote my spidev2.0 and spidev2.1 usage.

Seth

P.S. I had compiled and made the BBBMini work for the board but not w/ the BBBlue yet.


(Seth) #16

@ppoirier,

Sir, I got it. sudo ./waf configure --board=blue! It works. I am compiling now but not cross-compiling. It will be another hour most likely.

Seth

P.S. Thank you sir.


(Seth) #17

Hello Everyone,

Here are more photos of my concerns: @SuzL and @MagicRuB.

I cannot connect yet. I have compiled the --board=blue for ardupilot. I have tried ping via the cmd line in a terminal and I even tried to connect by going to /usr/bin/ardupilot and using the cmd, chmod a+x blue-arducopter, I thought things would connect from your ideas SuzL.

I then went away from that directory and used the cmd, sudo ./blue-ardupilot, to run the system on my BBBlue.

I received some odd text as feedback. Please see the photos below.

REportII

The second photo is the terminal print from that, sudo ./blue-arducopter, cmd.

Seth


(Seth) #18

Hello Everyone,

As you all know, I became very excited to see things, esp. from your end of things, in a space where the BBBlue could support the MavLink and Mission Planner software. In haste, I asked away w/out thinking of your time and how long you have been exercising your right to perform with ArduPilot.

Anyway…I got things up and running. Yea!

Seth


(peterbarker) #19

The sudo should not be necessary, and is a hint that something earlier
in your command sequence might have gone awry. However, it’s working for
you, so carry on :slight_smile:


(Seth) #20

@peterbarker,

Hello,

I see you were right. I actually had to perform the cmd in the directory to suit my needs but I will keep find tuning things until I can use it w/out sudo as a cmd.

Seth

P.S. Thank you for your input.